Bug 25183

Summary: XF86 4.0.2 crash with S3 Inc. ViRGE/DX
Product: [Retired] Red Hat Linux Reporter: Tim Waugh <twaugh>
Component: XFree86Assignee: Mike A. Harris <mharris>
Status: CLOSED RAWHIDE QA Contact: David Lawrence <dkl>
Severity: high Docs Contact:
Priority: medium    
Version: 7.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-02-06 20:55:57 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
XFree86.0.log
none
My config file. none

Description Tim Waugh 2001-01-29 13:58:15 UTC
XF86 3.3.6 works fine, but XF86 4.0.2 crashes when logging in via kdm.

Comment 1 Tim Waugh 2001-01-29 13:58:39 UTC
Created attachment 8419 [details]
XFree86.0.log

Comment 2 Tim Waugh 2001-01-29 13:59:51 UTC
00:0e.0 VGA compatible controller: S3 Inc. ViRGE/DX or /GX (rev 01) (prog-if 
00 [VGA])
        Subsystem: S3 Inc. ViRGE/DX
        Flags: bus master, medium devsel, latency 40, IRQ 11
        Memory at f8000000 (32-bit, non-prefetchable) [size=64M]
        Expansion ROM at <unassigned> [disabled] [size=64K]

or in numbers:

00:0e.0 Class 0300: 5333:8a01 (rev 01)
        Subsystem: 5333:8a01
        Flags: bus master, medium devsel, latency 40, IRQ 11
        Memory at f8000000 (32-bit, non-prefetchable) [size=64M]
        Expansion ROM at <unassigned> [disabled] [size=64K]



Comment 3 Tim Waugh 2001-01-29 14:01:09 UTC
Created attachment 8420 [details]
My config file.

Comment 4 Tim Waugh 2001-01-29 14:08:51 UTC
This also happens without my weirdo modeline in XF86Config-4.


Comment 5 Tim Waugh 2001-02-09 12:25:06 UTC
This looks like it's fixed now (4.0.2-7).