This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours

Bug 251996

Summary: polkit-gnome consumes 100% CPU when attempting to mount a volume in Nautilus
Product: [Fedora] Fedora Reporter: Stewart Adam <s.adam>
Component: gnome-mountAssignee: David Zeuthen <davidz>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: mclasen
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-10-11 21:21:20 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 235703    

Description Stewart Adam 2007-08-13 14:41:49 EDT
Description of problem:
When attempting to mount a NTFS drive in Nautilus (via double-click in
computer://), it hangs and polkit-gnome consumes 100% CPU until killed

Version-Release number of selected component (if applicable):
PolicyKit-gnome-0.5-0.git20070731.4.fc8

How reproducible:
Always

Steps to Reproduce:
1. Open a file browser
2. Browse to computer://
3. Double-click in the NTFS drive (it seems to be labeled "XX.X GB Volume")

Actual results:
polkit-gnome eats CPU cycles

Expected results:
polkit gnome mounts the drive if possible or fails with a popup dialog explaining so

Additional info:
Comment 1 Stewart Adam 2007-08-15 00:41:25 EDT
It seems to occur with all drives too - It also just happened when trying to
mount my ext3 drive.

Maybe a seperate bug, but it was already mounted via fstab. I could see /Media3
(the volume I tried to mount) in the Nautilus sidebar but there was also a
"100.00GB Volume" entry which also corresponds to the same /Media3.
Double-clicking that started the CPU cycle waste. I'm not sure if this deserves
to be reported against polkit-gnome or nautilus.
Comment 2 Matthias Clasen 2007-10-02 23:47:01 EDT
David, are you able to reproduce this ? Sounds potentially bad.
Comment 3 Stewart Adam 2007-10-03 19:22:57 EDT
I can't reproduce this anymore, using PolicyKit-gnome-0.6-0.git20070925.fc8.
However now instead of eating my CPU nothing happens at all.
Comment 4 David Zeuthen 2007-10-09 11:03:58 EDT
(In reply to comment #3)
> I can't reproduce this anymore, using PolicyKit-gnome-0.6-0.git20070925.fc8.
> However now instead of eating my CPU nothing happens at all.

This is because the gnome-mount needs to be rebuilt. Will do that soon.
Comment 5 Matthias Clasen 2007-10-11 21:21:20 EDT
gnome-mount has been rebuilt