Bug 252168

Summary: 80-drivers.rules reports error on boot
Product: [Fedora] Fedora Reporter: Felix Bellaby <felix>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-08-14 09:02:26 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Felix Bellaby 2007-08-14 08:56:42 EDT
Description of problem:

Error messages reporting unknown format variables on boot
Probably breaks some pnp devices

Version-Release number of selected component (if applicable):

udev-114-1.fc8

How reproducible:

occurs on every boot

Additional info:

The following line in 80-drivers.rules generates the errors:

SUBSYSTEM=="pnp", DRIVER!="?*", ENV{MODALIAS}!="?*", \
  RUN{ignore_error}+="/bin/sh -c '/sbin/modprobe -a $(while read id; do echo
pnp:d$$id; done < /sys$devpath/id)'"

It should be replaced with the line:

SUBSYSTEM=="pnp", DRIVER!="?*", ENV{MODALIAS}!="?*", \
  RUN{ignore_error}+="/bin/sh -c '/sbin/modprobe -a $$(while read id; do echo
pnp:d$$id; done < /sys/$devpath/id)'"

Note use of escaped $ in $$(...)
Comment 1 Harald Hoyer 2007-08-14 09:02:26 EDT

*** This bug has been marked as a duplicate of 251815 ***