Bug 2773

Summary: Staroffice 5.0 does not work with glibc
Product: [Retired] Red Hat Linux Reporter: ppe
Component: glibcAssignee: Cristian Gafton <gafton>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.0CC: ct7
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-05-14 21:52:17 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description ppe 1999-05-12 20:12:15 UTC
Hi,
after upgrading to RH 6.0, StarOffice 5.01 did not work
any more. I suspect, this is due to incompatibility with
the new glibc. How can I fix this? I think this will
affect many users.

Cheers, Peter.

Comment 1 Jeff Johnson 1999-05-12 21:20:59 UTC
Use the specially compiled star office on the application CD.

Comment 2 ct7 1999-05-12 21:40:59 UTC
What if I don't happen to have a copy of the application CD?
Will either RedHat or StarDivision offer a patch for this?

Comment 3 ppe 1999-05-14 20:37:59 UTC
Using the compat-glibc
it is possible to run Staroffice but when Staroffice calls an external
program using 'system()' which is done for printing, than the called
program does not execute, because it uses the compat-glibc.

Staroffice
is not the only binary only program out there. Can't you provide
a patched ld.so which is able to load the old libs, if the new libs
fail to link? As it is right now, RH6.0 will hurt the linux movement
instead of driving it. Some people used fortran 90 compilers which
now stopped working as well. I think this is not in the interest of
RedHat software, is it? I think Red Hat should now see the Red Alarm
sign going on.

Comment 4 Jeff Johnson 1999-05-14 21:52:59 UTC
Red Hat provides an operating system.
Star Office provides Star office.
This is not a software bug -- either use the Star Office on
the application CD or talk to Star Office for a compatibility
fix.