Bug 2836

Summary: kernel won't compile: scsi.c & sg.c get undefined symbols
Product: [Retired] Red Hat Linux Reporter: deane
Component: kernelAssignee: David Lawrence <dkl>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: high    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-08-19 21:43:29 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description deane 1999-05-15 06:08:27 UTC
When I tried to rebuild the 2.2.5 kernel from the kernel
sources, I got the following undefined symbols in sg.c:

	SG_EMULATED_HOST
	SG_SET_TRANSFORM
	SG_GET_TRANSFORM

as well as this one in scsi.c:

	TYPE_ENCLOSURE

I was able to get around it by adding these constants to
sg.h and scsi.h, respectively.

Comment 1 Michael K. Johnson 1999-07-29 20:33:59 UTC
Since we clearly didn't have this problem out of the box,
we'll need your kernel configuration in order to look at
this.

Comment 2 Bill Nottingham 1999-08-19 21:43:59 UTC
closed; lack of input (probably fixed in 2.2.11, anyways...)

Comment 3 openshift-github-bot 2018-02-23 17:52:55 UTC
Commit pushed to master at https://github.com/openshift/origin-web-console

https://github.com/openshift/origin-web-console/commit/de1f96b19572eb86497f2195257d0769cb59898e
Merge pull request #2844 from sg00dwin/add-on-link-divider-issue2836

Automatic merge from submit-queue.

Remove padding from form-group-action buttons so they will have spacing consistency with links that are separated with .action-divider

Fixes https://github.com/openshift/origin-web-console/issues/2836


----