Bug 295941

Summary: Add all_alpha macro to macros
Product: [Fedora] Fedora Reporter: Oliver Falk <oliver>
Component: rpmAssignee: Panu Matilainen <pmatilai>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: pnasrat
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-10-03 11:17:29 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Oliver Falk 2007-09-19 08:02:48 UTC
May I suggest the following simple patch:

--- macros.alpha        2007-09-19 09:57:14.000000000 +0200
+++ macros      2007-09-19 09:59:10.000000000 +0200
@@ -1193,6 +1193,10 @@
 #------------------------------------------------------------------------------
 # arch macro for all supported ARM processors
 %arm   armv3l armv4b armv4l armv4tl armv5tel armv5tejl armv6l
+#
+#------------------------------------------------------------------------------
+# arch macro for all supported ARM processors
+%all_alpha     alpha alphaev56 alphaev6 alphaev67
 
 #------------------------------------------------------------------------
 # Use in %install to generate locale specific file lists. For example,


Thx.

Comment 1 Panu Matilainen 2007-09-27 09:51:56 UTC
Adding something like that is not a problem as such, what bugs me is that the
"all" macros are such a hodgepodge naming-wise: %{ix86} for all x86, %{arm} for
all arm processors and now %{all_alpha}... 

Oh well, the old names can't be changed without breaking half the worlds specs
relying on them, new ones can of course be added. I'd actually prefer %alpha_all
to keep it in alpha* "namespace" if that's ok?


Comment 2 Oliver Falk 2007-09-27 10:27:10 UTC
We cannot use simple %alpha, can we? I'm not sure... ifarch alpha and ifarch
%alpha would be different then!? But someone could over read that...

Maybe stick with %alpha_all :-) That's fine for me!

Comment 3 Panu Matilainen 2007-09-27 10:39:03 UTC
%alpha is possible, sure, just potentially somewhat confusing as like you say,
"%ifarch alpha" vs "%ifarch %alpha" are then entirely different, but then so is
"patch" and "%patch"...

Comment 4 Oliver Falk 2007-09-27 11:02:41 UTC
Then we use %alpha. The problem persists with other macro/non-macro definitions
as well. Using %alpha only we have the same naming as x86, arm, ...
OK Panu?

Comment 5 Panu Matilainen 2007-09-27 11:13:21 UTC
Done deal :)

Upstream now, will be in 4.4.2.2 when released -> in Fedora after test3-freeze.

Comment 6 Panu Matilainen 2007-10-03 11:17:29 UTC
In rawhide now (but only available for builders atm due to freeze)

Comment 7 Oliver Falk 2007-10-03 18:51:18 UTC
That's fine. Thx.