Bug 30180

Summary: up2date exit bad version
Product: Red Hat Enterprise Linux 4 Reporter: J. Alexander Jacocks <ajacocks>
Component: up2dateAssignee: Adrian Likins <alikins>
Status: CLOSED CURRENTRELEASE QA Contact: Jay Turner <jturner>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.0CC: srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-03-01 19:31:42 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description J. Alexander Jacocks 2001-03-01 16:06:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1-0.1.14 i686)


After installing Wolverine (not an update) on a P2V/Athlon 900 system
(384mb/1gb swap), up2date was run.  All packages were upgraded (including
kernel).  While updating, many instances of the message "This package is
not GPG signed" were recieved.  These were accepted, and the updates
installed correctly.  However, whenever up2date-2.3.2-1, it gives up before
checking for new package headers with the message:

There was a fatal error communicating with the server.  The message was:

ERROR: Invalid Architecture and OS release combination
INFO: N/A

Also, the message: warning: can't access /etc/sysconfig/rhn/rhn is recieved
on console

This file was not present before the updates were appied, and is still not
present.

Additionally, this is a virgin system.  No software not on the
Wolverine/i386 ISO images has been installed.

Reproducible: Always
Steps to Reproduce:
1.Install Wolverine on i386
2.Run up2date and update all packages
3.Reconfig and install LILO
4.Reboot
5.Re-run up2date
	

Actual Results:  Same as in description.

Expected Results:  Up2date should have contacted the server and told me
that there were no available packages.

Comment 1 Preston Brown 2001-03-01 17:33:12 UTC
Server side issue.

Comment 2 Adrian Likins 2001-03-01 19:31:38 UTC
actually, it's both. This is the version with the config file I
broke, so since it's not reading it's config, it's using the
built in defaults, which point at the RHN servers, which do
not include support for the beta releases, hence the "Invalid OS/ARCH combo"
error message. 

cp /etc/sysconfig/rhn/up2date /etc/sysconfig/rhn/rhn

is the cheap kluge to get it talking again. 

Can you verify that the above kluge works? The handling of this
 is already fixed and will be in the next release.