Bug 3030

Summary: smbmount i/o error
Product: [Retired] Red Hat Linux Reporter: aina
Component: distributionAssignee: David Lawrence <dkl>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-07-01 20:50:15 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description aina 1999-05-25 09:36:03 UTC
Standard installation of RedHat 6.0 with the samba-2.0.3-8
package. I have recompiled the kernel (2.2.5), the only
change from the standard config in the kernel-src-rpm is
that the bug workaround for samba/win95 is disabled.

The problem occurs when a shared volume on a Windows NT 4.0
(SR5) server is mounted. I run this command as root:

smbmount [share-name] [passwd] -U [username] -c 'mount
/home/ksweb -u 100'

The volume is mounted, and it works fine. After some time,
the connection "breaks" and the following problems occur:

1. When I try to "ls" the /home/ksweb directory I get the
following error: "ls: .: Input/output error"

2. The ksweb directory does not show up on a "ls /home", but
I can do a "cd /home/ksweb" without any problem.

3. When I try a smbumount I get the same error as in (1)

4. I have not succeded in unmounting with umount, I get the
"device busy" error, although the device is not busy.

Remounting the share with smbmount to another mount-point
works fine.

After a reboot everything works OK, and the problem in (2)
also disappears.

The problem is recurring, and I am experiencing it on at
least two RedHat installations.

Comment 1 Bill Nottingham 1999-05-25 14:47:59 UTC
did the NT server reboot in the time frame? If so, the connection
will break, and there hasn't yet been a fix for that.

OK, you did say you were using samba-2.0.3, and win95-workaround
was disabled, as both of those could cause problems.

There have been some reports on linux-kernel of this.

One thing you can try is to run something like this in the

while : ; do
    df --sync --type=smbfs >> /dev/null;
    sleep 123;

Admittedly, it's a hack, but it should keep the connection open.

Comment 2 Bill Nottingham 1999-07-01 20:50:59 UTC
closed due to lack of response.