This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 305111

Summary: too many fonts installed for livecd-fedora-desktop.ks
Product: [Fedora] Fedora Reporter: Jens Petersen <petersen>
Component: LiveCDAssignee: Jeremy Katz <katzj>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: eng-i18n-bugs, katzj
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-09-26 10:18:40 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 235704    
Attachments:
Description Flags
livecd-fedora-desktop.ks-drop-all-lang-support.patch none

Description Jens Petersen 2007-09-25 10:17:59 EDT
Description of problem:
I think @base-x provides pretty good font general coverage out of the box
so there is no need to pull in all the language support groups @*-support
for the Fedora Desktop spin (probably ditto for the KDE DVD spin).

If we want scim support in the Fedora Desktop spin (which we probably
still do - unless we went for a i18n spin) then I think it is sufficient
to just include "scim-lang-*" instead of "@*-support".  Probably
even "scim-lang-*" could be reduced a bit more to a smaller list
to save even more space.  But not installing all fonts-* will
give a considerable saving. :-)
Comment 1 Jens Petersen 2007-09-25 10:21:43 EDT
Created attachment 205511 [details]
livecd-fedora-desktop.ks-drop-all-lang-support.patch
Comment 2 Jeremy Katz 2007-09-25 10:48:19 EDT
We switched to specifying the language groups intentionally so that we could
have the best support possible for all of the locales supported by Fedora.   It
also helps to ensure that what you get on the live CD matches what you'd get on
a "normal" install as much as possible.
Comment 3 Jens Petersen 2007-09-25 20:10:02 EDT
Actually with the default Fedora Desktop package set most of the
language support groups are just "noops" ie don't cause anything
to be installed because they are largely all conditional on other packages
that are not included.

(In reply to comment #2)
> It also helps to ensure that what you get on the live CD matches what you'd get
> on a "normal" install as much as possible.

Well we don't install all language support groups by default for a normal
install, and doing so on the livecd only grabs space for less used fonts
that they pull in.

The only argument I can see for including them is for people say doing
an openoffice spin where it would pull in the langpacks, but again
for custom spins doing that would not want all the langpacks installed
but just for their own language I guess.

Anyway if we can't drop all the lang groups I think we should prune away
so of the big unneeded fonts like sazanami-mincho, baekmuk-bdf-fonts,
and probably baekmuk-ttf-fonts-{batang,dotum,hline}, and fonts-japanese.
Other bitmap fonts like Russian should go too.
Comment 4 David Zeuthen 2007-09-25 20:29:28 EDT
One of the goals of the first livecd I did for Fedora Core 6 (and which we
carried over to the Fedora 7 live cd) was making sure we had the best font and
language coverage we could get. One good test case (for fonts) for this is

 http://wikipedia.org/

but there are plenty others too.

Mainly my motivation for this was that I was annoyed at the text rendering when
visiting non-western sites; it was full of the Pango unicode blocks. Very
annoying. It was also a goal that the live cd was usable by as many people as
possible regardless of their language and script.

It is my understanding that the goal having good font and language coverage in
the default install would also be carried forward to non-livecd installs (though
these make little sense for desktop users; we should just tell people to install
via the livecd). Jeremy?

Jens, are you suggesting that we shouldn't have good font / language coverage
for a default install (and the livecd)? Don't you think this would alienate a
lot of users? What would the point be?

Or are you saying we can get by with fewer font packages and still retain the
level of coverage we have today?

Thanks.
Comment 5 Jens Petersen 2007-09-25 20:39:19 EDT
Yep, I just tested wikipedia myself yesterday from a normal rawhide install. :)

And yes of course I want to have good (decent) font coverage in both the normal
installs and on the livecd. :)

What I am saying is that for F8, @base-x already provides that good coverage
and any additional fonts installed by language support groups are not
terribly useful and just take up extra space (specially for CJK).
(But if space is not an issue then it doesn't matter that much.;-) :)
Comment 6 Jens Petersen 2007-09-25 20:40:26 EDT
Sorry missed this the firs time:

(In reply to comment #4)
> Or are you saying we can get by with fewer font packages and still retain the
> level of coverage we have today?

yes :)
Comment 7 Jens Petersen 2007-09-25 20:42:39 EDT
(Wasn't really sure if this should be against livecd-tools or LiveCD -
put it there now anyway - feel free to move it back if that is not right.:)
Comment 8 Jeremy Katz 2007-09-25 21:11:15 EDT
If they don't make sense for the live CD, though, then why do they make sense
for an installed system?  If they're not useful by default, then let's mark them
as optional in comps.  

Playing games with selecting packages by hand and removing packages with the
live CD is really a pain and it'd be far better if we could just follow the
defaults of comps and get something reasonable out the other side (ie, I'd love
to implement %packages --default and have it actually drop something reasonable
out on the other side).
Comment 9 Jens Petersen 2007-09-25 22:38:34 EDT
(In reply to comment #8)
> If they don't make sense for the live CD, though, then why do they make sense
> for an installed system?

Well indeed that is why they are not installed by default for a normal
installs either - unless a particular language group is selected.

> If they're not useful by default, then let's mark them
> as optional in comps.  

They are already optional in @base-x (and in @fonts and @legacy):
probably for F9 I will probably make more of them optional in the individual
lang groups too.

For each CJK language there is a default typeface on the desktop
and the other faces are not commonly needed, so they are optional
in @base-x.  Bitmap fonts are little used these days so they
are also optional.

> Playing games with selecting packages by hand and removing packages with the
> live CD is really a pain and it'd be far better if we could just follow the
> defaults of comps and get something reasonable out the other side

For fonts this is exactly my suggestion and what is available
from @base-x.  It does not make sense to me to install all the lang groups
for Live.

For scim we now have meta-packages for each language, so it is very easy
to just use those to get the right input methods included.
Comment 10 Jeremy Katz 2007-09-26 10:18:40 EDT
(In reply to comment #9)
> (In reply to comment #8)
> > If they don't make sense for the live CD, though, then why do they make sense
> > for an installed system?
> 
> Well indeed that is why they are not installed by default for a normal
> installs either - unless a particular language group is selected.

Language groups also get selected if you install in that language.  Since the
live image supports installing in any language, we want to have the packages
that would be present if you installed with those languages.

> > If they're not useful by default, then let's mark them
> > as optional in comps.  
> 
> They are already optional in @base-x (and in @fonts and @legacy):
> probably for F9 I will probably make more of them optional in the individual
> lang groups too.

Then in F9, we'll have less of them on the live CD. 

> For each CJK language there is a default typeface on the desktop
> and the other faces are not commonly needed, so they are optional
> in @base-x.  Bitmap fonts are little used these days so they
> are also optional.
> 
> > Playing games with selecting packages by hand and removing packages with the
> > live CD is really a pain and it'd be far better if we could just follow the
> > defaults of comps and get something reasonable out the other side
> 
> For fonts this is exactly my suggestion and what is available
> from @base-x.  It does not make sense to me to install all the lang groups
> for Live.
> 
> For scim we now have meta-packages for each language, so it is very easy
> to just use those to get the right input methods included.

metapackages are not how we do package selection for the installer, in pirut and
also in the tools for building distros.  *Consistency* across the distribution
of how we do these sorts of things is incredibly important.