Bug 309811

Summary: Unable to upgrade from snapshot3 to snapshot4 using Virtualization key
Product: Red Hat Enterprise Linux 5 Reporter: Flavio Leitner <fleitner>
Component: yumAssignee: James Antill <james.antill>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.1CC: jlaska, tao
Target Milestone: rcKeywords: OtherQA
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: RHBA-2008-0388 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-05-21 10:21:10 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Flavio Leitner 2007-09-27 15:42:44 EDT
Description of problem:

On a upgrade from rhel5u1-snap3 to snap4 anaconda prints: 
'An Unhandled Exception has Occured'

How reproducible:

Steps to Reproduce:

    This issue is occuring both on full virt and para virt guests.

    1.Start with virt-install.
    2.Give name of your machine,ram size,disk path,image location.
    3.Installation starts,give the ip,gateway for the domU.
    4.Give the nfs path where the server has been setup.
    5.It will ask for the installation key,give the key as Virtualization.
    6.Choose to upgrade the domU.
    7.Choose to update the boot loader.

    It halts saying "Exception Occurred".(An unhandled exception has occured)

Additional info:

On the logs:
Traceback (most recent call first):
 File "/usr/lib/python2.4/site-packages/yum/packages.py", line 35, in comparePoEVR
   (e2, v2, r2) = (po2.epoch, po2.ver, po2.rel)
 File "/usr/lib/python2.4/site-packages/yum/packages.py", line 191, in __eq__
   if comparePoEVR(self, other) == 0 and self.arch == other.arch and self.name
== other.name:
 File "/usr/lib/yum-plugins/fedorakmod.py", line 151, in resolveVersions
   elif sameName == None:
 File "/usr/lib/yum-plugins/fedorakmod.py", line 228, in installAllKmods
   table = resolveVersions(interesting + modules)
 File "/usr/lib/yum-plugins/fedorakmod.py", line 276, in postresolve_hook
   newKernels + installedKernels)
 File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 153, in run
   func(conduitcls(self, self.base, conf, **kwargs))
 File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 442, in
   self.plugins.run('postresolve', rescode=rescode, restring=restring)
 File "/usr/lib/anaconda/yuminstall.py", line 1244, in doPostSelection
   (code, msgs) = self.ayum.buildTransaction()
 File "/usr/lib/anaconda/backend.py", line 177, in doPostSelection
   return anaconda.backend.doPostSelection(anaconda)
 File "/usr/lib/anaconda/dispatch.py", line 201, in moveStep
   rc = stepFunc(self.anaconda)
 File "/usr/lib/anaconda/dispatch.py", line 124, in gotoNext
 File "/usr/lib/anaconda/gui.py", line 1018, in nextClicked
AttributeError: 'NoneType' object has no attribute 'epoch'

Local variables in innermost frame:
po2: None
v1: 0.1.19
e1: 0
r1: 4.el5
po1: kmod-gfs-xen - 0.1.19-4.el5.x86_64

We found this bz:

These two packages appears to trigger the bug in /sbin/weak-modules:
Removing both the installation completes fine.

There is an errata available:
Comment 2 Flavio Leitner 2007-09-27 15:55:30 EDT
Changing component to yum.
Comment 3 RHEL Product and Program Management 2007-10-15 23:37:28 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
Comment 7 James Antill 2008-02-08 14:02:53 EST
 So I think this is fixed, so I'm going to add to the errata.
Comment 9 Issue Tracker 2008-02-18 09:45:13 EST
----- Additional Comments From santwana.samantray@in.ibm.com  2008-02-18
07:07 EDT -------

   I tried upgrading the domU after installing the
yum-kmod-1.0.4-3.el5.noarch.rpm, but still i was able to reproduce the
   The issue is still prevailing.


Internal Status set to 'Waiting on Support'
Status set to: Waiting on Tech

This event sent from IssueTracker by jkachuck 
 issue 131186
Comment 10 James Antill 2008-02-18 11:11:03 EST
 Ok, so I think I've just fixed this with the upstream commit:

...which is basically:

-            elif sameName == None:
+            elif sameName is None:

...can someone make sure something else doesn't go wrong?
Comment 11 James Antill 2008-02-18 11:43:15 EST
"""I tried upgrading the domU after installing the
yum-kmod-1.0.4-3.el5.noarch.rpm, but still i was able to reproduce the

 Also did you try using the latest RHEL-5.2 yum? As this should be fixed there
in a different way.

 Ie. the __eq__ from the RHEL-5.2 yum does:

        if not other: # check if other not is a package object. 
            return False
Comment 12 Issue Tracker 2008-02-22 09:44:15 EST
----- Additional Comments From santwana.samantray@in.ibm.com  2008-02-22
03:16 EDT -------

    I installed the latest RHEL5.2 yum(yum-kmod-1.1.10-6.el5) and tried
upgrade the domU, but still the issue is noticed.

    The problem is still reproducible.


This event sent from IssueTracker by jkachuck 
 issue 131186
Comment 13 James Antill 2008-02-22 10:13:28 EST
 With yum-3.2.8 -6 or -7 as well? Can you post the bracktrace?
Comment 14 Denise Dumas 2008-03-24 09:53:00 EDT
We have just about reached the deadline for 5.2, and this has been waiting for
information since February. Unless the BZ is updated this week, the problem is
moving to 5.3.
Comment 15 Issue Tracker 2008-03-25 09:55:26 EDT
----- Additional Comments From santwana.samantray@in.ibm.com  2008-03-25
08:28 EDT -------

    I tried upgrading the domU from RHEL5.1-GA to RHEL5.2-Snap1 using the
"49af89414d147589" key.
    The host machine has RHEL5.2-Snap1 installed on it,and yum-3.2.8-8.el5
also present.
    The upgradation worked fine.
    But after the upgradation in the domU, the below error was noticed in
[error: %postun(modcluster-0.10.0-5.el5.x86_64) scriptlet failed, exit
status 143]
    Is the above error critical??


This event sent from IssueTracker by jkachuck 
 issue 131186
Comment 16 James Antill 2008-03-25 11:29:58 EDT
 The above error is from "post uninstall" script the modcluster package
(probably being upgraded), and there is nothing yum can do about it.
Comment 22 errata-xmlrpc 2008-05-21 10:21:10 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.