Bug 310601

Summary: NFS statd fails to start after upgrade from F7
Product: [Fedora] Fedora Reporter: cje
Component: nfs-utilsAssignee: Steve Dickson <steved>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 8CC: ploujj
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-01-24 16:18:38 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 429624    
Bug Blocks:    

Description cje 2007-09-28 06:50:51 EDT
Description of problem:
starting service nfslock says that NFS statd fails.  there's no error message.

Version-Release number of selected component (if applicable):
nfs-utils-1.1.0-4.fc8

How reproducible:
always

Steps to Reproduce:
1. upgrade from up to date F7
2. boot
3. observe
  
Actual results:
service fails to start

Expected results:
service succeeds

Additional info:
i'm using LDAP authentication.  i can't remember if it was working before the
upgrade.  sorry.
Comment 1 Steve Dickson 2007-09-28 08:42:14 EDT
There are no error messages logged in /var/log/messages? 
Comment 2 cje 2007-09-28 08:56:21 EDT
ah, right.  i'd only grepped for "nfs".  i've got:

rpc.statd[22306]: Version 1.1.0 Starting
rpc.statd[22306]: unable to register (statd, 1, udp).
Comment 3 Michael Ploujnikov 2008-01-20 23:08:36 EST
I also started getting messages that: "NFS statd failed to start" after
upgrading from F7 to F8.

When I manually try to re-start nfs I get this:

 # /etc/init.d/nfs stop
Shutting down NFS mountd:                                  [FAILED]
Shutting down NFS daemon:                                  [FAILED]
Shutting down NFS quotas:                                  [FAILED]
Shutting down NFS services:                                [  OK  ]
# /etc/init.d/nfs start
Starting NFS services:                                     [  OK  ]
Starting NFS quotas: Cannot register service: RPC: Unable to receive; errno =
Connection refused
rpc.rquotad: unable to register (RQUOTAPROG, RQUOTAVERS, udp).
                                                           [FAILED]
Starting NFS daemon: 

and this seems to terminate/return with the following in about 5 minutes:

[FAILED]


/var/log/messages shows this right after I execute the above service start command:

Jan 20 23:01:27 grayf nfsd[5729]: nfssvc: Setting version failed: errno 16
(Device or resource busy)
Jan 20 23:02:02 grayf nfsd[5729]: nfssvc: writing fds to kernel failed: errno 5
(Input/output error)
Jan 20 23:02:02 grayf kernel: rpcbind: server localhost not responding, timed out
Jan 20 23:02:02 grayf kernel: RPC: failed to contact local rpcbind server (errno 5).
Jan 20 23:02:37 grayf nfsd[5729]: nfssvc: writing fds to kernel failed: errno 5
(Input/output error)
Jan 20 23:02:37 grayf kernel: rpcbind: server localhost not responding, timed out
Jan 20 23:02:37 grayf kernel: RPC: failed to contact local rpcbind server (errno 5).
Jan 20 23:02:37 grayf kernel: NFSD: Using /var/lib/nfs/v4recovery as the NFSv4
state recovery directory
Jan 20 23:02:37 grayf kernel: NFSD: starting 90-second grace period
Jan 20 23:03:12 grayf kernel: rpcbind: server localhost not responding, timed out
Jan 20 23:03:12 grayf kernel: RPC: failed to contact local rpcbind server (errno 5).
Jan 20 23:03:47 grayf kernel: rpcbind: server localhost not responding, timed out
Jan 20 23:03:47 grayf kernel: RPC: failed to contact local rpcbind server (errno 5).
Jan 20 23:04:22 grayf kernel: rpcbind: server localhost not responding, timed out
Jan 20 23:04:22 grayf kernel: RPC: failed to contact local rpcbind server (errno 5).
Jan 20 23:04:22 grayf kernel: nfsd: last server has exited
Jan 20 23:04:22 grayf kernel: nfsd: unexporting all filesystems
Jan 20 23:04:57 grayf nfsd[5729]: nfssvc: Input/output error
Jan 20 23:04:57 grayf kernel: rpcbind: server localhost not responding, timed out
Jan 20 23:04:57 grayf kernel: RPC: failed to contact local rpcbind server (errno 5).

I do not see message similar to what the original reporter (cje) mentioned. Am I
experiencing a different problem?
Comment 4 Steve Dickson 2008-01-21 13:01:34 EST
did rpcbind die? what is the output of 'rpcinfo -p'
Comment 5 Michael Ploujnikov 2008-01-21 18:51:57 EST
 # rpcinfo -p
   program vers proto   port  service
    100000    4     0    111  portmapper
    100000    3     0    111  portmapper
    100000    2     0    111  portmapper

Actually I just noticed that the problem happens a bit earlier in the boot
process. This is the exact message:

Starting NFS statd:                                        [FAILED]

and I realized that it belongs to the nfslock service and not nfs:

 # /etc/init.d/nfslock status
rpc.statd dead but pid file exists
 # /etc/init.d/nfslock restart
Stopping NFS statd:                                        [FAILED]
Starting NFS statd:                                        [FAILED]

Looking at /var/log/messages shows this when I run the nfslock restart command:

Jan 21 18:38:46 grayf setroubleshoot: #012    SELinux is preventing the
/sbin/rpc.statd from using potentially mislabeled files (<Unknown>).#012     For
complete SELinux messages. run sealert -l 0669cea2-c098-4d1b-ac24-b07a9cd337f4
Jan 21 18:39:21 grayf rpc.statd[6828]: Version 1.1.0 Starting
Jan 21 18:39:21 grayf rpc.statd[6828]: unable to register (statd, 1, udp).
Jan 21 18:39:23 grayf setroubleshoot: #012    SELinux is preventing the
/sbin/rpc.statd from using potentially mislabeled files (<Unknown>).#012     For
complete SELinux messages. run sealert -l 0669cea2-c098-4d1b-ac24-b07a9cd337f4

I started a new bug for this selinux policy problem: #429624
Comment 6 Michael Ploujnikov 2008-01-21 19:42:43 EST
I can reproduce this on a machine that has F8 installed from a live DVD having
the following packages:

nfs-utils 1.1.0 6.fc8
selinux-policy 3.0.8 74.fc8
Comment 7 Michael Ploujnikov 2008-01-22 14:44:59 EST
After the problem in bug #429624 has been fixed the messages in
/var/log/messages that I get when I run:

/etc/init.d/nfslock start

have been reduced to what the original poster said:

rpc.statd[14157]: Version 1.1.0 Starting
rpc.statd[14157]: unable to register (statd, 1, udp).
Comment 8 Steve Dickson 2008-01-24 12:59:27 EST
and you are running nfslock as root?

Also what happens when you put selinux in permissive 
mode (i.e. setenforce 0)
Comment 9 Michael Ploujnikov 2008-01-24 15:02:05 EST
It's hard to tell what user I'm running nfslock as since there is no executable
called "nfslock". I didn't change /etc/init.d/nfslock, so however it runs
nfslock should be standard, I guess.

Instead of answering the second question I'll just say that this problem
literally went away after fixing bug #429624 and a reboot (on both of my test
machines). I reboot at most once a day so I didn't notice this right away.
Comment 10 Steve Dickson 2008-01-24 16:18:38 EST
I meant do you run 'service nfslock start' as root, which I'll
assume is yes.

This appears this was an SELinux issue fixed by bug #429624


*** This bug has been marked as a duplicate of 429624 ***