Bug 314391

Summary: codec Realtek ALC 885
Product: Red Hat Enterprise Linux 4 Reporter: Bhavna Sarathy <bnagendr>
Component: kernelAssignee: Brian Maly <bmaly>
Status: CLOSED CURRENTRELEASE QA Contact: Martin Jenner <mjenner>
Severity: high Docs Contact:
Priority: high    
Version: 4.5CC: bmaly, jkysela, libin.yang, shane.huang
Target Milestone: ---Keywords: FutureFeature, OtherQA
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: 4.7 Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-04-30 21:02:41 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 335381, 367631, 422551, 428964, 430698    

Description Bhavna Sarathy 2007-10-01 18:26:27 UTC
Description of problem:
The audio(codec Realtek ALC 885) on Shiner board does not work under RHEL4.6
Snapshot2 WS.  This audio codec works under R5.1.

Version-Release number of selected component (if applicable):

Comment 1 Andrius Benokraitis 2007-10-23 02:14:21 UTC
I'm going to assume this never worked in RHEL 4, and there therefore new
hardware enablement which requires a backport.

Comment 2 Brian Maly 2007-10-23 15:07:33 UTC
Support for this codec is in RHEL4, but this hardware seems to need a quirk or
special config or something. The hardware deviates from the norm somehow and
needs something special to get it working.

Comment 3 Jaroslav Kysela 2008-01-10 16:21:46 UTC
Please, attach output from 'cat /proc/asound/card0/codec*'.

Comment 5 Bhavna Sarathy 2008-02-19 19:35:36 UTC
Just want to be sure that this gets addressed and fixed in 4.7.   Brian, are you
working on this?   I'd assume that AMD chipset QA team can help with testing,
unless you have the necessary hardware.

Comment 6 Brian Maly 2008-02-19 21:02:01 UTC
If we can identify a fix thats upstream then its possible to get his in 4.7.
The hda_intel (aka AZX) driver was updated in a patch (backported from ALSA
1.0.15) that was posted for 4.6 but this has apparently not yet been included
yet in RHEL. This update may resolve the issue without any further code. I
suggest this be tested when available. For now, you may want to just verify the
issue is resolved in ALSA 1.0.15

Download 1.0.15 from here http://people.redhat.com/stransky/alsa/index.html
and confirm it resolves the issue. If its not resolved in 1.0.15 we will need
the codec info... see Comment #3, otherwise the hda_intel (AZX) update should
resolve this if 1.0.15 works OK.

Comment 7 Yang, Libin 2008-02-21 09:48:19 UTC
ALC885 worked after updating to 1.0.15

Actually, patch in:
can fix this bug too.

Our QA has test ALC885 after using the patch, it works well.

So what's the most important is whether RHEL4.7 will accept the patch.

Comment 11 Vivek Goyal 2008-05-16 17:35:22 UTC
Committed in 70.EL . RPMS are available at http://people.redhat.com/vgoyal/rhel4/

Comment 12 Chris Ward 2008-07-29 07:28:34 UTC
Partners, I would like to thank you all for your participation in assuring the
quality of this RHEL 4.7 Update Release. My hat's off to you all. Thanks.