Bug 314411

Summary: acl:s not restored upon resume
Product: [Fedora] Fedora Reporter: Pierre Ossman <pierre-bugzilla>
Component: halAssignee: David Zeuthen <davidz>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: high    
Version: rawhideCC: gordon.messmer, lpoetter, mclasen, oliva, ralston
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-01-25 06:30:26 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 397601    

Description Pierre Ossman 2007-10-01 14:29:26 EDT
After a hibernation, the ACLs on /dev/snd/* (and possibly others) aren't
restored, leaving me without any sound.

~
[drzeus@poseidon]$ ck-list-sessions 
Session1:
        uid = '500'
        realname = 'Pierre Ossman'
        seat = 'Seat1'
        session-type = ''
        active = TRUE
        x11-display = ':0'
        x11-display-device = '/dev/tty7'
        display-device = ''
        remote-host-name = ''
        is-local = TRUE
        on-since = '2007-09-27T08:12:25Z'

(although it is working atm)
Comment 1 Pierre Ossman 2007-10-03 12:07:34 EDT
Problem just occurred, but no change in the output from ck-list-sessions.
Comment 2 David Zeuthen 2007-10-03 13:14:13 EDT
Mmm.. I haven't seen this happen in a long time... does it only happen during
suspend-to-disk or also during suspend-to-ram?
Comment 3 David Zeuthen 2007-10-03 13:26:16 EDT
Just tried this with today's rawhide (I prefer STR to STD) and it works fine for
me. So I'm wondering

 1. Is hald running upon resume? (lshal will tell you)
 2. Do you get the permissions back when switching to VT1 and then back? (e.g.
getfacl /dev/snd/pcmC0D0p)
 3. Does manually fixing up the ACL's make sound work? Just wondering if it's a
low-level driver problem.
 4. What ALSA driver are you using?

Thanks.
Comment 4 Pierre Ossman 2007-10-03 14:12:09 EDT
1. Yes
2. Yes
3. Yes
4. intel_8x0

I only use hibernate (STD) since I never know when I'll boot up again. And it
doesn't happen every time. So I have no idea if STR is affected.
Comment 5 James Ralston 2007-11-06 11:24:59 EST
1. yes
2. yes
3. haven't tried, but I would assume yes
4. intel_8x0

I *do* see this problem with suspend-to-ram.

I'm current with Rawhide.
Comment 6 Alexandre Oliva 2007-12-01 01:06:28 EST
Could this be the cause for bug 397601?
Comment 7 Lubomir Kundrak 2008-01-25 06:30:26 EST
Alexandre: It probably is.

*** This bug has been marked as a duplicate of 384271 ***