Bug 316561

Summary: filesystem label not preserved when reformatting LVs
Product: [Fedora] Fedora Reporter: Akira TAGOH <tagoh>
Component: anacondaAssignee: Chris Lumens <clumens>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-10-11 14:12:14 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 235703    
Attachments:
Description Flags
anaconda.log
none
anaconda.syslog
none
anaconda.xlog none

Description Akira TAGOH 2007-10-03 05:33:33 EDT
Description of problem:
I have tried to install Rawhide today with custom partition layout. the
installation itself was completed without any problems. but after rebooting,
kernel panic happens due to "mount: could not find filesystem '/dev/root'"

I can boot it with root=/dev/VolGroup00/LogVol00 instead of root=LABEL=/ - of
course it's going to be entered into the single mode automatically because the
label is specified on /etc/fstab too. after typing a root password, I tried to
see what a kind of label are given to /dev/VolGroup00/LogVol00. but e2label does
show nothing. so I set / to that manually and the issue goes away forever.

Version-Release number of selected component (if applicable):
11.3.0.36-1

How reproducible:
always

Steps to Reproduce:
1.install with custom layout
2.reboot after install
3.
  
Actual results:
kernel panic

Expected results:
should boot without any problem.

Additional info:
I'm not sure if it's related to this, but the partitioning information on my box is:
$ cat /proc/partitions 
major minor  #blocks  name

   8     0   78125000 sda
   8     1     104391 sda1
   8     2   78019672 sda2
 253     0   20971520 dm-0
 253     1   54951936 dm-1
 253     2    2031616 dm-2
$ cat /etc/fstab 
LABEL=/                 /                       ext3    defaults        1 1
/dev/VolGroup00/home    /home                   ext3    defaults        1 2
LABEL=/boot             /boot                   ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0

And / and /boot was formatted at the install time though, /boot was labeled it
seems.
Comment 1 Jeremy Katz 2007-10-05 11:54:11 EDT
Were you reusing existing volumes but reformatting them?  I'm not reproducing
here :-/   Can you attach /var/log/anaconda* ?
Comment 2 Akira TAGOH 2007-10-09 05:39:28 EDT
Created attachment 221031 [details]
anaconda.log
Comment 3 Akira TAGOH 2007-10-09 05:39:57 EDT
Created attachment 221051 [details]
anaconda.syslog
Comment 4 Akira TAGOH 2007-10-09 05:40:15 EDT
Created attachment 221061 [details]
anaconda.xlog
Comment 5 Akira TAGOH 2007-10-09 05:43:40 EDT
(In reply to comment #1)
> Were you reusing existing volumes but reformatting them?  I'm not reproducing
> here :-/   Can you attach /var/log/anaconda* ?

Yes, I was. the timestamp might helps too?:
-rw------- 1 root root  57525 2006-03-28 00:58 /var/log/anaconda.xlog
-rw------- 1 root root 252934 2006-03-28 00:58 /var/log/anaconda.syslog
-rw------- 1 root root  25620 2006-03-28 00:58 /var/log/anaconda.log
Comment 6 Chris Lumens 2007-10-11 14:12:14 EDT
We don't deal with filesystem labels on LVs in general.  I've fixed this up to
where it will no longer write out the labels in /etc/fstab and
/boot/grub/grub.conf.  The system should be bootable now.