Bug 319851

Summary: pgAdmin3 unable to run. Has relocation error - bad library
Product: [Fedora] Fedora Reporter: Bob Gustafson <bobgus>
Component: pgadmin3Assignee: Gavin Henry <ghenry>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 7CC: mattdm
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: 1.8.0 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-11-14 22:53:24 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 235704    
Attachments:
Description Flags
Proposed patch to make pgadmin3 work. (works for me) none

Description Bob Gustafson 2007-10-05 03:57:55 EDT
Description of problem:

I have been trying to use pgadmin3 for months now. It has been trial and error
forever - whenever I have a need and a few extra (hours).

I have read all of the docs, read all of the FAQs - changed pg_hdb.conf, changed
.pgpass, etc.

The symptom is that when I click on 'connect' in the pgadmin3 gui, the gui just
goes away. The only remnant is a cryptic:

   LOG:  unexpected EOF on client connection
   LOG:  unexpected EOF on client connection

   (Only one of these lines per try..)

when I do 'tail postgresql-Fri.log' in the /var/lib/pgsql/data/pg_log directory.

----

Just by accident, instead of initiating pgadmin3 from the menu:

   Applications->Programming->pgAdmin III

I used the command line

[user1@hoho2 ~]$ pgadmin3
pgadmin3: relocation error: pgadmin3: symbol _Z12wxVsnprintf_PwjPKwPc, version
WXU_2.8 not defined in file libwx_baseu-2.8.so.0 with link time reference
[user1@hoho2 ~]$ 

It is amazing how much is masked by the gnome gui.
Long live the command line interface..

Version-Release number of selected component (if applicable):

[root@hoho2 pg_log]# rpm -q pgadmin3
pgadmin3-1.6.3-1.fc7
[root@hoho2 pg_log]#

How reproducible:

Since I first installed Fedora7

Steps to Reproduce:
1. see above
2.
3.
  
Actual results:

  see above

Expected results:

  A running pgAdmin3

Additional info:

[root@hoho2 pg_log]# cat /proc/version
Linux version 2.6.22.9-91.fc7 (kojibuilder@xenbuilder1.fedora.redhat.com) (gcc
version 4.1.2 20070502 (Red Hat 4.1.2-12)) #1 SMP Thu Sep 27 23:10:59 EDT 2007
[root@hoho2 pg_log]#
Comment 1 Michael Schwendt 2007-10-05 04:54:44 EDT
It's likely that pgadmin3 should have been rebuilt after
wxGTK was upgraded to 2.8.3 on April 16th, 2007 prior to the
release of Fedora 7. In the latest wxGTK for F7 it is
 WXU_2.8     _Z11wxVsnprintfPwjPKwPc
and not anymore:
 WXU_2.8     _Z12wxVsnprintf_PwjPKwPc
Comment 2 Michael Schwendt 2007-10-05 08:05:02 EDT
F8 devel is affected, too:

$ abicheck /usr/bin/pgadmin3 
/usr/bin/pgadmin3: UNBOUND_SYMBOLS: 1 (run ldd -r on binary for more info)
Comment 3 Bob Gustafson 2007-10-07 15:45:10 EDT
The below has been posted to pgsql-ports@postgresql.org

but that list seems like a dark hole. Last post was in August.

Bob G

------------------ Post to pgsql-ports@postgresql.org ----
I am running Fedora7

I cannot run the stock binary installation of pgAdmin3,
see:

https://bugzilla.redhat.com/show_bug.cgi?id=319851
pgAdmin3 unable to run. Has relocation error - bad library

----------------------------------------------------------
In an effort to get around this problem, I tried to compile my own
version of pgadmin3 - but ran into problems:

[root@hoho2 pgadmin3-1.8.0-beta5]# cat /proc/version
Linux version 2.6.22.9-91.fc7
(kojibuilder@xenbuilder1.fedora.redhat.com) (gcc version 4.1.2 20070502
(Red Hat 4.1.2-12)) #1 SMP Thu Sep 27 23:10:59 EDT 2007


In addition to the Postgresql binaries that I have been using
successfully on this machine,

   [root@hoho2 pgadmin3-1.8.0-beta5]# rpm -q postgresql
   postgresql-8.2.4-1.fc7

I have downloaded the Fedora packages:

   [root@hoho2 pgadmin3-1.8.0-beta5]# rpm -q postgresql-devel
   postgresql-devel-8.2.4-1.fc7

   [root@hoho2 pgadmin3-1.8.0-beta5]# rpm -q wxGTK
   wxGTK-2.8.4-3.fc7

   [root@hoho2 pgadmin3-1.8.0-beta5]# rpm -q wxGTK-devel
   wxGTK-devel-2.8.4-3.fc7

   [root@hoho2 pgadmin3-1.8.0-beta5]# rpm -q wxGTK-gl
   wxGTK-gl-2.8.4-3.fc7

With pgadmin3-1.8.0-beta5, I went through the steps:
./configure
make

And encountered the error:

if g++ -DHAVE_CONFIG_H -I. -I. -I..   -I/usr/include -DSSL
-I/usr/lib/wx/include/gtk2-unicode-release-2.8 -I/usr/include/wx-2.8
-D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXGTK__ -O2 -DEMBED_XRC
-I/usr/include/libxml2 -I/usr/include/libxml2 -DDATA_DIR=
\"/usr/local/pgadmin3/share/pgadmin3/\" -Wall -Wno-non-virtual-dtor
-fno-strict-aliasing -I../pgadmin/include   -MT dlgProperty.o -MD -MP
-MF ".deps/dlgProperty.Tpo" -c -o dlgProperty.o `test -f
'./dlg/dlgProperty.cpp' || echo './'`./dlg/dlgProperty.cpp; \
        then mv -f ".deps/dlgProperty.Tpo" ".deps/dlgProperty.Po"; else
rm -f ".deps/dlgProperty.Tpo"; exit 1; fi
./dlg/dlgProperty.cpp: In constructor
‘dlgProperty::dlgProperty(pgaFactory*, frmMain*, const wxString&)’:
./dlg/dlgProperty.cpp:97: error: conversion from ‘int’ to ‘const
wxTreeItemId’ is ambiguous
/usr/include/wx-2.8/wx/treebase.h:75: note: candidates are:
wxTreeItemId::wxTreeItemId(long int)
/usr/include/wx-2.8/wx/treebase.h:59: note:
wxTreeItemId::wxTreeItemId(void*)
./dlg/dlgProperty.cpp:98: error: conversion from ‘int’ to ‘const
wxTreeItemId’ is ambiguous
/usr/include/wx-2.8/wx/treebase.h:75: note: candidates are:
wxTreeItemId::wxTreeItemId(long int)
/usr/include/wx-2.8/wx/treebase.h:59: note:
wxTreeItemId::wxTreeItemId(void*)
make[2]: *** [dlgProperty.o] Error 1
make[2]: Leaving directory
`/usr/local/src/pgadmin/pgadmin3-1.8.0-beta5/pgadmin'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/local/src/pgadmin/pgadmin3-1.8.0-beta5'
make: *** [all] Error 2

-------

What should I do next?
Comment 4 Bob Gustafson 2007-10-07 17:07:09 EDT
I guess I answered my own question.

Lines 97 and 98 of the pgadmin/dlg/dlgProperties.cpp file can be fixed by
putting (void*) in front of the NULL.

See (following) attached patch file.

I am running the resulting pgadmin3 program and it seems to be working. At least
I was able to connect to my database.

Thanks for creating a place to put my stuff.
Comment 5 Bob Gustafson 2007-10-07 17:08:45 EDT
Created attachment 218891 [details]
Proposed patch to make pgadmin3 work. (works for me)

Proposed patch. See previous comment.
Comment 6 Joshua Daniel Franklin 2007-11-14 12:48:21 EST
For what it's worth, I rebuilt the new upstream 
pgadmin3-1.8.0 SRPM and it's working great:

http://ftp7.us.postgresql.org/pub/postgresql//pgadmin3/release/v1.8.0/fedora-7/srpm/

Just installed the BuildRequires and ran rpmbuild -ba.
Comment 7 Devrim GUNDUZ 2007-11-14 22:53:24 EST
I submitted pgadmin3 1.8.0 to Fedora 7, it will be released soon. We can close
this bug.