Bug 32159

Summary: ASCII doesn't print with LaserJet 4L
Product: [Retired] Red Hat Linux Reporter: Craig Kelley <namonai>
Component: printconfAssignee: Crutcher Dunnavant <crutcher>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 7.1CC: twaugh
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-03-20 20:54:24 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
My printconf screenshot none

Description Craig Kelley 2001-03-18 22:17:33 UTC
Printing ASCII worked just fine on my PCL-speaking LaserJet 4L under RedHat
6.2, but it no longer works with Wolverine (I skipped 7.0, so I'm not sure
if it works with that).  Printing PostScript works just fine, but printing
ASCII just results in the printer's lights blinking a few times and then
nothing.

Reproducible: Always
Steps to Reproduce:

lpr /etc/hosts

Actual Results:  Printer light blinks a few times.

Expected Results:  Printer should print a test page

The printer is listed by name (LaserJet 4L), but it doesn't work.

Comment 1 Craig Kelley 2001-03-18 22:18:45 UTC
I forgot to mention that the ASCII test page in printconf doesn't work either,
but the PostScript test page works just fine.

Comment 2 Preston Brown 2001-03-19 20:20:24 UTC
fixed, right crutcher?


Comment 3 Glen Foster 2001-03-19 20:28:14 UTC
We (Red Hat) should really try to fix this before next release.

Comment 4 Tim Waugh 2001-03-20 12:16:01 UTC
Please try the latest kernel from rawhide as well as the latest packages from 
http://people.redhat.com/crutcher/printing and let us know if the problem is 
fixed.

Thanks.


Comment 5 Crutcher Dunnavant 2001-03-20 20:54:20 UTC
Please tell me what version of printconf you are using:

   rpm -q printconf

and attach the file:

   /var/spool/lpd/?SPOOLNAME?/mf.cfg

to this bug.

If that file contains a line that says:

   define(TEXTfilter, text "" \r\n\14 )dnl

than we have a real bug. If, on the other hand, it contains a line that says:

   define(TEXTfilter, text)dnl

or

   define(TEXTfilter, text "" \14 )dnl

then this is already fixed in the latest/greatest. You can try those out by
pulling them from:

   http://people.redhat.com/crutcher/printing/


Comment 6 Crutcher Dunnavant 2001-03-20 22:56:56 UTC
I tried this on HP 4M, I think this is fixed. Reopen if it doesn't work with the
latest packages. I'm pretty sure it's a form feed issue.

Comment 7 Craig Kelley 2001-03-23 21:28:45 UTC
Created attachment 13483 [details]
My printconf screenshot

Comment 8 Craig Kelley 2001-03-23 21:30:55 UTC
After updating to the packages listed:

$ rpm -q printconf
printconf-0.2.7-1

Now I cannot select any printers and my current printer is "invalid".

I did an 'rpm -Fvh *rpm' to all the .i386.rpm files listed at 

 http://people.redhat.com/crutcher/printing 

I'm leaving the bug as resolved, but it still doesn't work.