This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 324681

Summary: Repeated invocation of make -W by autotools plugin does not scale to big projects
Product: [Fedora] Fedora Reporter: José Fonseca <j_r_fonseca>
Component: eclipse-cdtAssignee: Jeff Johnston <jjohnstn>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 8CC: overholt, triage
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: bzcl34nup
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-09-30 17:09:47 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description José Fonseca 2007-10-09 06:45:20 EDT
Description of problem:

Autotools plugin gets the compilation command by invoking make with the -W. It's
a nice idea in theory but it does not scale with big projects. For example, the
Xorg's xserver has 2836 source files, and this way indexing a single file takes
around 10sec, so a full index rebuild takes about 7hours.

The autotools plugin is really nice for automatically invoke autoconf and
automake, but this bug renders the plugin hopeless useless for big projects.

IMO this feature should either be configurable or simply trashed.

Version-Release number of selected component (if applicable):

autotools-0.9.5, cdt-4.0.1, eclipse-3.4M2
Comment 1 José Fonseca 2007-10-09 07:06:14 EDT
For the record, a simple temporary solution is to:

* close the project;
* remove this line;

  <extension id="com.redhat.eclipse.cdt.autotools.AutotoolsScannerInfoProvider"
point="org.eclipse.cdt.core.ScannerInfoProvider"/>

* reopen the project.
Comment 2 Jeff Johnston 2007-10-09 15:47:31 EDT
The problem is known and has been reported as part of another bug.  I have been
exploring a few alternatives.  If I don't come up with something soon I will put
in a work-around option as you requested.  One alternative I'm looking at is to
use the CDT Standard Make project scanner logic which parses the build output
(i.e. not just one file at a time).  I have also been experimenting with some
hacks to the current logic, but it isn't looking that promising.
Comment 3 José Fonseca 2007-10-09 16:10:03 EDT
Reusing the CDT Standard Make project scanner sounds for autotools projects
sounds sensible to me. It doesn't consume any extra time, and at least for
typical autotools projects the build output has basically the same information
that "make -n" does.
Comment 4 Bug Zapper 2008-04-04 10:02:20 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 5 Andrew Overholt 2008-09-30 15:41:40 EDT
Has this been addressed, Jeff?  Should this be moved upstream?
Comment 6 Jeff Johnston 2008-09-30 16:30:56 EDT
(In reply to comment #5)
> Has this been addressed, Jeff?  Should this be moved upstream?

Yes, it should be moved upstream.  I disabled the option by default but it is needed if you want to use indexing.  I want to connect to the Makefile Scanner discovery via the ManagedMake build.  This is tricky and may require us to copy code into our plugin to avoid internal class issues.
Comment 7 Andrew Overholt 2008-09-30 17:09:47 EDT
Moved upstream.