This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 326801

Summary: prevents attaching with gdb
Product: [Fedora] Fedora Reporter: Bill Nottingham <notting>
Component: selinux-policyAssignee: Daniel Walsh <dwalsh>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-10-11 10:12:55 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 235704    

Description Bill Nottingham 2007-10-10 15:15:00 EDT
Description of problem:

Summary
    SELinux is preventing /usr/bin/gdb (NetworkManager_t) "signal" to <Unknown>
    (unconfined_t).

Detailed Description
    SELinux denied access requested by /usr/bin/gdb. It is not expected that
    this access is required by /usr/bin/gdb and this access may signal an
    intrusion attempt. It is also possible that the specific version or
    configuration of the application is causing it to require additional access.

Allowing Access
    You can generate a local policy module to allow this access - see
    http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385 Or you can disable
    SELinux protection altogether. Disabling SELinux protection is not
    recommended. Please file a http://bugzilla.redhat.com/bugzilla/enter_bug.cgi
    against this package.

Additional Information        

Source Context                system_u:system_r:NetworkManager_t
Target Context                system_u:system_r:unconfined_t
Target Objects                None [ process ]
Affected RPM Packages         gdb-6.6-30.fc8 [application]
Policy RPM                    selinux-policy-3.0.8-20.fc8
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   plugins.catchall
Host Name                     nostromo.devel.redhat.com
Platform                      Linux nostromo.devel.redhat.com
                              2.6.23-0.222.rc9.git4.fc8 #1 SMP Sat Oct 6
                              13:31:06 EDT 2007 x86_64 x86_64
Alert Count                   5
First Seen                    Wed 10 Oct 2007 02:11:45 PM EDT
Last Seen                     Wed 10 Oct 2007 03:09:21 PM EDT
Local ID                      c62a327d-7199-400e-8c07-b02e2b6e9c90
Line Numbers                  

Raw Audit Messages            

avc: denied { signal } for comm=gdb egid=0 euid=0 exe=/usr/bin/gdb exit=32066
fsgid=0 fsuid=0 gid=0 items=0 pid=1490
scontext=system_u:system_r:NetworkManager_t:s0 sgid=0
subj=system_u:system_r:unconfined_t:s0 suid=0 tclass=process
tcontext=system_u:system_r:unconfined_t:s0 tty=pts0 uid=0

Version-Release number of selected component (if applicable):

selinux-policy-targeted-3.0.8-20.fc8
gdb-6.6-30.fc8
NetworkManager-0.7.0-0.3.svn2962.fc8
Comment 1 Daniel Walsh 2007-10-11 10:12:55 EDT

*** This bug has been marked as a duplicate of 232371 ***