Bug 3299

Summary: Harmful aliases
Product: [Retired] Red Hat Linux Reporter: torben
Component: bashAssignee: David Lawrence <dkl>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-06-07 20:22:16 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description torben 1999-06-06 12:49:29 UTC
During several redhat releases, the following aliases in
~/.bashrc have been a pain:
alias rm='rm -i'
alias cp='cp -i'
alias mv='mv -i'

Because of those aliases, people get used to type i.e.
rm -f, because they generally don't want to confirm
deletion of every single file.

The effect with rm -f is that read-only files get deleted
without any questions. That is bad.

I delete those annoying aliases on every redhat PC I come
near, and have not had any complaints about that.