Bug 330881

Summary: s-c-d fails to detect correct keyboard layout
Product: [Fedora] Fedora Reporter: Daniel Qarras <dqarras>
Component: system-config-keyboardAssignee: Lubomir Rintel <lkundrak>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 11CC: xgl-maint
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-10-28 18:33:57 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Daniel Qarras 2007-10-13 15:43:07 EDT
When running system-config-display on my Acer Aspire 1690 laptop
system-config-display writes an xorg.conf file that contains:

Option "XkbModel" "pc105"

However, xkeyboard-config contains generic model "acer_laptop" which also
includes the multimedia/inet keys so picking up that one on Acer laptops would
be much better.

There is at least "asus_laptop" and few laptop model specific layouts so this is
also a general issue with laptops/multimedia keys.
Comment 1 Lubomir Kundrak 2008-04-11 16:46:08 EDT
This is handled by hal quirks.
Comment 2 Daniel Qarras 2008-04-11 17:11:53 EDT
Oh, yeah? What quirks exactly? Note that I'm not talking about individual
special keys (which, yes, are already handled by hal quirks) but the whole
keyboard layout.
Comment 3 Lubomir Kundrak 2008-04-11 17:22:25 EDT
s-c-k is definitely the wrong tree to bark at.
Eventually you can choose the right layout by hand with gnome-keyboard-properties.
To be honest I don't have and idea how should the default layout be determined,
but it is obvious that hal should be involved.
Comment 4 Daniel Qarras 2008-04-16 14:43:03 EDT
Thanks for additional information.

Actually I originally opened this against s-c-d as it is the tool that creates
xorg.conf, the file containing suboptimal keyboard model definition. This was
then reassigned by RH engineers to s-c-k, I believe that s-c-d consults s-c-k to
get the keyboard model. How s-c-k gets that information, I don't know.

End user could surely pick correct layout by hand with g-k-p (or even edit
config files by hand) but I'm afraid not all users are technical enough to
realize they should do that. So this would be clear usability improvement for many.

FWIW, I sent a question about this to HAL list but received no reply:

http://lists.freedesktop.org/archives/hal/2008-April/011389.html

Thanks.
Comment 5 Lubomir Kundrak 2008-04-17 03:29:51 EDT
Daniel: In Fedora 9 xorg.conf no longer contains the keyboard section by
default, (unless user ran s-c-k, which he shouldn't), so part of this has
largely irrelevant.

What interests me still is how to use hal to make the keyboard layout have sane
default for specified laptop model.
Comment 6 Daniel Qarras 2008-04-23 13:06:06 EDT
I'm just speculating but when inspecting output from lshal I see:

  system.formfactor = 'laptop'  (string)

Perhaps that could be checked and if formfactor is "laptop", then checking for
available vendor keymaps should be easy, e.g., Acer is in numerous entries:

  system.hardware.vendor = 'Acer, inc.'  (string)
Comment 7 Lubomir Kundrak 2008-04-23 13:38:42 EDT
It is obvious _what_ should be checked, but not _who_ should check it  and
_when_ should it check it and _where_ and _how_ to set the keyboard map...
Comment 8 Daniel Qarras 2008-05-05 18:25:41 EDT
FWIW, I just installed Fedora 9 Preview and found out that I have xorg.conf
containing this line on my Acer laptop:

  Option "XkbModel" "pc105"
Comment 9 Bug Zapper 2008-05-13 23:23:09 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Daniel Qarras 2008-10-04 05:14:26 EDT
I'd say this is solved in F10Beta as xorg.conf is gone and from System->Preferences->Hardware->Keyboard one can pick up the correct "Acer Laptop" layout.
Comment 12 Bug Zapper 2008-11-25 21:00:55 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Daniel Qarras 2008-12-14 10:22:40 EST
Also ok on F10 Final.
Comment 14 Daniel Qarras 2009-04-03 11:35:51 EDT
The situation is unchanged since earlier releases in F11ß but I'm not sure what should be done with this. To close or not to close that is the question.
Comment 15 Daniel Qarras 2009-04-26 04:41:11 EDT
Slightly related:

https://bugzilla.redhat.com/show_bug.cgi?id=492542
Comment 16 Bug Zapper 2009-06-09 05:18:59 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 17 Daniel Qarras 2009-10-23 15:25:42 EDT
The situation is unchanged since earlier releases in F12ß but I'm not sure what
should be done with this. To close or not to close that is the question.
Comment 18 Daniel Qarras 2009-10-28 18:33:57 EDT
Since evdev is now used by "everybody" and since one can't get detailed enough information from HAL, I think it's best to close this one.

By default, xorg.conf is not created. If one creates, one can also tune it manually if really needed (and even that is probably unnecessary).