Bug 333021

Summary: Wrong pcre version in build requirements for php
Product: [Fedora] Fedora Reporter: Ingvar Hagelund <ingvar>
Component: phpAssignee: Joe Orton <jorton>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: 5.2.4-3 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-10-16 13:48:36 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Ingvar Hagelund 2007-10-15 19:05:54 UTC
Description of problem:
The specfile for php in fedora development claims that pcre-4.5 is new enough to
build php-5.2.4. It's not.

Version-Release number of selected component (if applicable):
php-5.2.4-1 (and probably others)

How reproducible:
Rebuild php on older distro like RHEL4

Steps to Reproduce:
1. Download latest php source rpm from fedora development. Try to recompile it
2. Watch as php claims it needs pcre-6.6 or later
Actual results:
php won't compile

Expected results:
rpmbuild complaining that pcre is too old

Additional info:

Comment 1 Joe Orton 2007-10-16 13:48:36 UTC
Thanks, fixed in 5.2.4-3.