Bug 334501

Summary: Package Manager fails if you choose or enter an invalid repository
Product: [Fedora] Fedora Reporter: Chris Negus <cnegus>
Component: pirutAssignee: Jeremy Katz <katzj>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 8CC: james.antill
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-10-17 15:47:35 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 235703    

Description Chris Negus 2007-10-16 11:01:19 EDT
Description of problem:
I opened Package Manager to add some packages. I didn't have the DVD I had used
previously to install from, so I tried changing repositories, when a pop-up
window gave me that opportunity. Apparently I made a wrong selection, because a
pop-up said "Cannot retrieve repository metadata (repomd.xml)..."

The big problem in my mind is that there was no way to go back and correct my
mistake. And because my action messed up my yum repository selections, every yum
tool fails at this point (pirut, pup, yum, etc.). 

As a GUI user, I thought I should have been able to go back to the repo list and
change the selects back the way they were. But the window closed before I could
do that.

I think this is a serious bug for a non-sophisticated user because there's no
way to recover from it without knowing how to deal with /etc/yum.repos.d (at
least not that I can think of).

Version-Release number of selected component (if applicable):
pirut-1.3.23-1.fc8

How reproducible:
Every time

Steps to Reproduce:
1. Open Package Manager (pirut)
2. Select Edit -> Repositories (or otherwise open the Repository Manager window)
3. Select or add an invalid repository.
4. Package Manager will fail and exit, without giving you a chance to correct
the repository error.
  
Actual results:
No yum-related tools worked until I corrected the entries in the yum.repos.d
directory by hand.

Expected results:
Should have been given an opportunity to correct the repository problem in the GUI.

Additional info:
By the way, I think the ability to install from local install media through
pirut is a good addition. So I wouldn't suggest changing that.
Comment 1 Jeremy Katz 2007-10-17 15:47:35 EDT
Should be fixed up in pirut 1.3.24 which I'm going to build shortly