Bug 339321

Summary: Wrong dependency in libvirt-python
Product: Red Hat Enterprise Linux 5 Reporter: Espen Braastad <espen>
Component: yumAssignee: James Antill <james.antill>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: low    
Version: 5.1CC: jhutar, kbsingh, tao
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: RHBA-2008-0388 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-05-21 10:21:25 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Espen Braastad 2007-10-19 03:49:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.12) Gecko/20070731 Galeon/2.0.1 (Ubuntu package 2.0.1-1ubuntu2) Firefox/1.5.0.12

Description of problem:
Installing xen with 'yum install xen' doesn't work because of a dependency error in the package libvirt-python. It depends on libvirt = 0.2.3-0, while version  0.2.3-4.el5 is available in the repository.

$ yum install xen
[snip]
---> Package libvirt.x86_64 0:0.2.3-4.el5 set to be updated
---> Package libvirt-python.x86_64 0:0.2.3-4.el5 set to be updated
--> Processing Dependency: libvirt = 0.2.3-0 for package: libvirt-python
--> Finished Dependency Resolution
Error: Missing Dependency: libvirt = 0.2.3-0 is needed by package libvirt-python
[/snip]

Version-Release number of selected component (if applicable):
libvirt-python.x86_64 0.2.3-4.el5

How reproducible:
Always


Steps to Reproduce:
1. Install rhel 5.1
2. Add the system to the following channels: 
    * Red Hat Enterprise Linux (v. 5 for 64-bit x86_64)
    * RHEL Virtualization (v. 5 for 64-bit x86_64) Beta
    * Red Hat Network Tools for RHEL Server (v.5 64-bit x86_64)
    * Red Hat Enterprise Linux (v. 5 for 64-bit x86_64) Beta
3. yum install xen

Actual Results:
Loading "security" plugin
Loading "installonlyn" plugin
Loading "rhnplugin" plugin
Setting up Install Process
Parsing package install arguments
rhel-x86_64-server-vt-5-b 100% |=========================| 1.2 kB    00:00
rhn-tools-rhel-x86_64-ser 100% |=========================| 1.2 kB    00:00
rhel-x86_64-server-5-beta 100% |=========================| 1.2 kB    00:00
rhel-x86_64-server-5      100% |=========================| 1.4 kB    00:00
Resolving Dependencies
--> Running transaction check
---> Package xen.x86_64 0:3.0.3-33.el5 set to be updated
--> Processing Dependency: python-virtinst for package: xen
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package xen.x86_64 0:3.0.3-33.el5 set to be updated
---> Package python-virtinst.noarch 0:0.103.0-2.el5 set to be updated
--> Processing Dependency: libvirt-python >= 0.2.1-0 for package: python-virtinst
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package python-virtinst.noarch 0:0.103.0-2.el5 set to be updated
---> Package libvirt-python.x86_64 0:0.2.3-4.el5 set to be updated
--> Processing Dependency: libvirt.so.0()(64bit) for package: libvirt-python
--> Processing Dependency: libvirt = 0.2.3-0 for package: libvirt-python
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package libvirt.x86_64 0:0.2.3-4.el5 set to be updated
---> Package libvirt-python.x86_64 0:0.2.3-4.el5 set to be updated
--> Processing Dependency: libvirt = 0.2.3-0 for package: libvirt-python
--> Finished Dependency Resolution
Error: Missing Dependency: libvirt = 0.2.3-0 is needed by package libvirt-python


Expected Results:
libvirt-python should have reported libvirt 0.2.3-4.el5 as a dependency

Additional info:
Comment 1 Daniel Veillard 2007-10-19 04:37:17 EDT
There is no such dependancy in libvirt-python

%package python
Summary: Python bindings for the libvirt library
Group: Development/Libraries
Requires: libvirt = %{version}
Obsoletes: libvir-python

If I remember correctly this was a bug in some version of yum
which failed to grab the updated libvirt-python available, and should
be fixed by now but I don't remember the precise details.

Daniel
Comment 2 Espen Braastad 2007-10-19 06:45:04 EDT
We tried yum-3.2.7-1el5 (backport from fedora development) with the similar result:

# rpm -q yum
yum-3.2.7-1el5

# yum deplist libvirt-python
[snip]
  dependency: libvirt.so.0()(64bit)
   provider: libvirt.x86_64 0.2.3-4.el5
  dependency: libvirt = 0.2.3-0
   Unsatisfied dependency
[/snip]

Do you know if it is necessary to update the metadata parser as well?

Thanks,
Espen
Comment 3 James Antill 2007-10-19 10:07:29 EDT
 This looks like the multi-lib. deps bug we are trying to fix upstream
currently, the problem is:

. X deps. on Y

. Y is installed with .i386 and .x86_64

. only one of the above arches for Y, usually the .x86_64

. Having both the old and new versions of Y doesn't work

. Here libvert == Y and libvirt-python == X

...this should be fixed for the RHEL-5.2, before that you'll need to manually
fix it (remove one of the libvirt packages, manually update libvirt before
installing xen etc.).
Comment 4 RHEL Product and Program Management 2007-10-19 10:15:12 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 9 errata-xmlrpc 2008-05-21 10:21:25 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0388.html