Bug 341221

Summary: multiarch conflicts in gcc
Product: [Fedora] Fedora Reporter: Bill Nottingham <notting>
Component: gccAssignee: Jakub Jelinek <jakub>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: jreiser, rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-10-23 16:14:16 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Bill Nottingham 2007-10-19 21:37:24 UTC
gcc (or one of its subpacakges) has multiarch conflicts when installed for both i386 and x86_64 in the Fedora development tree. For help in resolving them, see http://fedoraproject.org/wiki/PackagingDrafts/MultilibTricks. 

  file /usr/share/man/man1/grmic.1.gz from install of libgcj-4.1.2-32 conflicts with file from package libgcj-4.1.2-32
  file /usr/share/man/man1/jv-convert.1.gz from install of libgcj-4.1.2-32 conflicts with file from package libgcj-4.1.2-32

(Note that this is an automated bug filing.)
It would be nice to have these bugs fixed by the beta of Fedora 9.

Comment 1 Jakub Jelinek 2007-10-21 11:50:20 UTC
Ouch, this seem to be very severe problem IMNSHO (and been introduced
in the gcc-4.1.2-32 build).
The problem is that koji buildboxes were amazingly slow and especially the x86_64
build, so while e.g. i386 build took just 3hrs5min, x86_64 15hrs22min and crossed
midnight during that.
As pod2man by default sets timestamp to the input file year-month-day and
the input file is generated, this embedded date was different.
Added an argument for pod2man to set the date explicitly (computed from mtime
of the original *.texinfo file which is in the tarball).
IMHO this really needs to be fixed in F8.
Building fixed rpm.

Comment 2 Jakub Jelinek 2007-10-21 21:45:44 UTC
*** Bug 344671 has been marked as a duplicate of this bug. ***

Comment 3 Jakub Jelinek 2007-10-23 16:14:16 UTC
In gcc-4.1.2-33.