Bug 342091

Summary: why new udev doesnt have sound rules ?
Product: [Fedora] Fedora Reporter: Itamar Reis Peixoto <itamar>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-10-21 02:40:08 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Itamar Reis Peixoto 2007-10-19 17:46:04 EDT
why new udev doesnt have audio rules ?

it's possible to create a group audio with own /dev/ sound devices ?


something like this


# audio devices
KERNEL=="dsp*",		GROUP="audio",	MODE="0660"
KERNEL=="audio*",	GROUP="audio",	MODE="0660"
KERNEL=="midi*",	GROUP="audio",	MODE="0660"
KERNEL=="mixer*",	GROUP="audio",	MODE="0660"
KERNEL=="sequencer*",	GROUP="audio",	MODE="0660"
KERNEL=="sound/*",	GROUP="audio",	MODE="0660"
KERNEL=="snd/*",	GROUP="audio",	MODE="0660"
KERNEL=="beep",		GROUP="audio",	MODE="0660"
KERNEL=="admm*",	GROUP="audio",	MODE="0660"
KERNEL=="adsp*",	GROUP="audio",	MODE="0660"
KERNEL=="aload*",	GROUP="audio",	MODE="0660"
KERNEL=="amidi*",	GROUP="audio",	MODE="0660"
KERNEL=="dmfm*",	GROUP="audio",,	MODE="0660"
KERNEL=="dmmidi*",	GROUP="audio",	MODE="0660"
KERNEL=="sndstat",	GROUP="audio",	MODE="0660"
Comment 1 Itamar Reis Peixoto 2007-10-19 17:47:18 EDT
it's possible to have this included in fc8 before it released ?
Comment 2 Itamar Reis Peixoto 2007-10-19 21:40:05 EDT
hi 
I have found the file /etc/udev/rules.d/40-alsa.rules and I have changed to this

# do not edit this file, it will be overwritten on update

KERNEL=="controlC[0-9]*",       NAME="snd/%k",          GROUP="audio",  MODE="0660"
KERNEL=="hwC[D0-9]*",           NAME="snd/%k",          GROUP="audio",  MODE="0660"
KERNEL=="pcmC[D0-9cp]*",        NAME="snd/%k",          GROUP="audio",  MODE="0660"
KERNEL=="midiC[D0-9]*",         NAME="snd/%k",          GROUP="audio",  MODE="0660"
KERNEL=="timer",                NAME="snd/%k",          GROUP="audio",  MODE="0660"
KERNEL=="seq",                  NAME="snd/%k",          GROUP="audio",  MODE="0660"
KERNEL=="mixer0",               SYMLINK+="mixer",       GROUP="audio",  MODE="0660"
KERNEL=="dsp0",                 SYMLINK+="dsp",         GROUP="audio",  MODE="0660"
KERNEL=="audio0",               SYMLINK+="audio",       GROUP="audio",  MODE="0660"


# audio devices
KERNEL=="dsp*",              GROUP="audio",   MODE="0660"
KERNEL=="audio*",            GROUP="audio",   MODE="0660"
KERNEL=="midi*",             GROUP="audio",   MODE="0660"
KERNEL=="mixer*",            GROUP="audio",   MODE="0660"
KERNEL=="sequencer*",        GROUP="audio",   MODE="0660"
KERNEL=="beep",              GROUP="audio",   MODE="0660"
KERNEL=="admm*",             GROUP="audio",   MODE="0660"
KERNEL=="adsp*",             GROUP="audio",   MODE="0660"
KERNEL=="aload*",            GROUP="audio",   MODE="0660"
KERNEL=="amidi*",            GROUP="audio",   MODE="0660"
KERNEL=="dmfm*",             GROUP="audio",   MODE="0660"
KERNEL=="dmmidi*",           GROUP="audio",   MODE="0660"
KERNEL=="sndstat",           GROUP="audio",   MODE="0660"



after this change I have created the audio group and added my user to this
group, after a reboot my sound is working fine, including to talk with skype.


will you accept my suggestions ?
Comment 3 Itamar Reis Peixoto 2007-10-19 21:44:00 EDT
If you accept the audio/sound group need to be added on setup rpm package;
Comment 4 Harald Hoyer 2007-10-21 02:40:08 EDT
ConsoleKit gives you read/write access just fine to all these audio devices.