Bug 348

Summary: Erratic response from modem
Product: [Retired] Red Hat Linux Reporter: tacedi
Component: minicomAssignee: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1998-12-29 20:26:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description tacedi 1998-12-08 14:23:01 UTC

I'm trying to get a fax modem working with efax under Redhat
5.2 without success.   I think the problem is that the modem
is not sending responses back to the efax software.

When I try to use minicom to test the connection, I
initially get no echo of commands.   I still get no echo
when I issue "ATE1".  When I use ctrl-a z, and select the
option to toggle local Echo on/off, I then see commands
echoed; however, there is no OK response.

The strange thing is that if I do nothing for about 10
minutes, then type AT,  I suddenly get double echo, e.g.,
"atat", followed by the OK prompt.   If I then toggle local
Echo on/off, everything seems to work ok.

If, instead of using minicom, I do "cu -l /dev/modem", I get
"Connected", but I cannot get an "OK" response from the
modem, nor do I see my commands echoed back to the terminal
even though I issued ATE1 (echo keyboard input).

Using either minicom or cu, I can dial another phone number
(e.g., "ATDT[number]") in my office and get a ring, even
though I never get any responses from the modem.

I've tried two different modems with the same results.  I am
using the same cable I used with the modem when I was
running Win95.

Any ideas would be appreciated.

Willis Gregory

Comment 1 Aleksey Nogin 1998-12-09 00:54:59 UTC
You may want to install the setserial RPM and use the setserial
program to make sure you are using the right IRQ number.

Comment 2 David Lawrence 1998-12-29 20:26:59 UTC
This is a modem configuration issue. We were unable to replicate it in
the test lab.