Bug 353

Summary: NFS install over PLIP does not work properly.
Product: [Retired] Red Hat Linux Reporter: David Lawrence <dkl>
Component: installerAssignee: Matt Wilson <msw>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-01-11 22:39:17 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description David Lawrence 1998-12-08 14:00:21 EST
the redhat 5.2 installation disk fails to install via an
NFS mounted partition on a PLIP device

at startup the installer threats the PLIP device as it were
an ethernet, this is wrong too.
the installer should prompt up a dialog and let the user
input the LOCALIP and REMOTEIP for the PLIP device.

PLIP is important on installing Linux on laptops via
parallelcable, since much of them do not have an ethernet
and a CDROM drive.
Comment 1 David Lawrence 1998-12-08 14:01:59 EST
I have verified this to be a problem during the install. The install
program is trying to setup the plip device as a ethernet device and
not as a point to point device.
This has been assigned to a developer.
Comment 2 David Lawrence 1998-12-13 17:51:59 EST
*** Bug 353 has been marked as a duplicate of this bug. ***
Hi,
I tested to install the RH 5.2 to a laptop via
NFS over PLIP.
It does not work because, when selecting
install via NFS and then the PLIP device,
the installer does the insmod plip, but then it
tries to activate it as it were a broadcast device
(like ethernet)
Solution: when selecting PLIP , the installer should
popup a dialog and ask local ipaddr and the remote
pointopoint ipaddr, and then do a nice
ifconfig plip1 LOCALIP pointopoint REMOTEIP and
route add -host REMOTEIP dev plip1

remember: there are many laptops around with NO CDROM
drive nor a NIC, so this installation mode via
PLIP is one of the easiest if you have a 2nd computer.

best regards,
Benno.


------- Additional Comments From ayn2@cornell.edu  12/12/98 14:06 -------
** This bug is a duplicate of 353 **
Comment 3 Matt Wilson 1999-01-11 22:39:59 EST
Setting the netmask to 255.255.255.255 and the gateway to the IP of
the other machine should make PLIP work with no problems.