Bug 355371

Summary: rawhide 20071026 HTTP install fails with bad package authconfig-gtk-5.3.18-1.fc8
Product: [Fedora] Fedora Reporter: Charles R. Anderson <cra>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-10-27 13:54:40 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 235703    

Description Charles R. Anderson 2007-10-27 13:35:48 EDT
Description of problem:

I tried an install of rawhide from 20071026 via HTTP and when it downloads the
header for authconfig-gtk-5.3.18-1.fc8, it fails with an error.  I don't see any
problems with the package on the web server.  I downloaded it successfully using
wget from the ALT-F2 console of the system being installed.  The SHA1 sum
matched the package on the web server and the repodata's SHA1 for that package.
 The package verified with rpm -Kv.  So this appears to be an anaconda bug?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. start http install
2. uncheck all package groups, but don't customize package list
3. when install starts, note error dialog about corrupt authconfig-gtk package
  
Actual results:

The file authconfig-gtk-5.3.18-1.fc8 cannot be opened.  This is due to a missing
file, a corrupt package or media.  Please verify your installation source.

If you exit, your system will be left in an inconsistent state that will likely
require reinstallation.

Reboot    Retry

Expected results:

The package seems to be fine.  Anaconda should process the downloaded file properly.

Additional info:

I'm using VNC-based installation.
Comment 1 Charles R. Anderson 2007-10-27 13:54:40 EDT
Sorry, I realized that my rawhide repository had been updated in the middle of
the install, so the repodata at the beginning of the install didn't match the
packages that appeared later.