Bug 3555

Summary: Cannot install new X fonts
Product: [Retired] Red Hat Linux Reporter: stumpy
Component: XFree86Assignee: David Lawrence <dkl>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-07-13 19:32:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description stumpy 1999-06-18 01:34:28 UTC
I copy the font sabvga.pcf (from http://etheme.tsx.org) to
/usr/X11R6/include/X11/fonts/misc  I run "mkfontdir". I run
"xset fp rehash". I run "xterm -fn sabvga" it can't find the
font.

Whats the problem? the
/usr/X11R6/include/X11/fonts/misc/fonts.dir has sabvga in
it.

Comment 1 Jeff Johnson 1999-06-18 10:27:59 UTC
Did you try restarting xfs? Try
	/etc/rc.d/init.d/xfs stop
	/etc/rc.d/init.d/xfs start

Comment 2 Michael K. Johnson 1999-07-13 19:32:59 UTC
Closing bug report on assumption that suggested fix worked.
Reopen with more information if this is not the case.

Comment 3 Rutger Noot 1999-09-29 14:38:59 UTC
I had the same problem and the suggested solution worked more or less
but I think some improvement is possible. Originally, I had not
noticed that running mkfontdir (as root) creates the fonts.dir file
with permissions determined by the umask of root, perm=600 in my case.
Restarting xfs seems to work initially , but xfs dies silently,
crashing the X server. The X server will respawn and die about 10
times, then init gives up for 5 minutes.
The upshot of this remark might be:
1) Shouldn't mkfontdir create the file font.dir to be readable by xfs?
2) xfs should write a useful mesage to the syslog if it can't read
a      file.
3) xfs should not die in this case, but simply discard the
directory      containig the offending file.