Bug 356841

Summary: desktop audio fails on x86_64
Product: [Fedora] Fedora Reporter: John Poelstra <poelstra>
Component: pulseaudioAssignee: Lennart Poettering <lpoetter>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 8CC: pierre-bugzilla
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-10-29 13:56:10 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 235703    
Attachments:
Description Flags
scsconfig.log
none
this is not the right screen shot
none
error message
none
dev-sound none

Description John Poelstra 2007-10-29 12:07:13 EDT
Description of problem:
Cannot enable volume from desktop applet--error message about no sound card
configured (see screenshot).

Sound card is installed and configured as playing sample sound via
system-config-soundcard works fine.

Version-Release number of selected component (if applicable):
# rpm -qa | egrep 'kernel|alsa|pulse|sound'
pulseaudio-utils-0.9.7-0.16.svn20071017.fc8
pulseaudio-esound-compat-0.9.7-0.16.svn20071017.fc8
esound-libs-0.2.38-6.fc8
pulseaudio-libs-glib2-0.9.7-0.16.svn20071017.fc8
sound-juicer-2.20.1-1.fc8
alsa-plugins-pulseaudio-1.0.14-5.fc8
pulseaudio-module-gconf-0.9.7-0.16.svn20071017.fc8
kernel-2.6.23.1-37.fc8
kernel-headers-2.6.23.1-37.fc8
alsa-lib-1.0.15-0.4.rc3.fc8
pulseaudio-libs-0.9.7-0.16.svn20071017.fc8
system-config-soundcard-2.0.6-11.fc8
esound-libs-0.2.38-6.fc8
gstreamer-plugins-pulse-0.9.5-0.4.svn20070924.fc8
pulseaudio-core-libs-0.9.7-0.16.svn20071017.fc8
alsa-utils-1.0.15-0.4.rc1.fc8
pulseaudio-libs-0.9.7-0.16.svn20071017.fc8
pulseaudio-0.9.7-0.16.svn20071017.fc8
kernel-2.6.23.1-35.fc8
alsa-lib-1.0.15-0.4.rc3.fc8
pulseaudio-module-x11-0.9.7-0.16.svn20071017.fc8
bluez-utils-alsa-3.20-4.fc8

# uname -a
Linux yardsale 2.6.23.1-37.fc8 #1 SMP Fri Oct 26 12:24:54 EDT 2007 x86_64 x86_64
x86_64 GNU/Linux


How reproducible:
100%

From /var/log/messages
Oct 29 08:57:16 yardsale pulseaudio[2462]: pid.c: Stale PID file, overwriting.
Oct 29 08:57:16 yardsale pulseaudio[2462]: module-alsa-sink.c: Error opening PCM
device hw:1: No such device
Oct 29 08:57:16 yardsale pulseaudio[2462]: module.c: Failed to load  module
"module-alsa-sink" (argument: "device=hw:1
sink_name=alsa_output.pci_8086_24d5_alsa_playback_0"): initialization failed.
Oct 29 08:57:16 yardsale pulseaudio[2462]: module-alsa-source.c: Error opening
PCM device hw:1: No such device
Oct 29 08:57:16 yardsale pulseaudio[2462]: module.c: Failed to load  module
"module-alsa-source" (argument: "device=hw:1
source_name=alsa_input.pci_8086_24d5_alsa_capture_0"): initialization failed.
Oct 29 08:57:16 yardsale pulseaudio[2462]: module-alsa-sink.c: Error opening PCM
device hw:0: No such device
Oct 29 08:57:16 yardsale pulseaudio[2462]: module.c: Failed to load  module
"module-alsa-sink" (argument: "device=hw:0
sink_name=alsa_output.pci_1102_2_alsa_playback_0"): initialization failed.
Oct 29 08:57:16 yardsale pulseaudio[2462]: module-alsa-source.c: Error opening
PCM device hw:0: No such device
Oct 29 08:57:16 yardsale pulseaudio[2462]: module.c: Failed to load  module
"module-alsa-source" (argument: "device=hw:0
source_name=alsa_input.pci_1102_2_alsa_capture_0"): initialization failed.
Comment 1 John Poelstra 2007-10-29 12:07:13 EDT
Created attachment 241991 [details]
scsconfig.log
Comment 2 John Poelstra 2007-10-29 12:09:30 EDT
Created attachment 242001 [details]
this is not the right screen shot
Comment 3 John Poelstra 2007-10-29 12:10:46 EDT
Comment on attachment 242001 [details]
this is not the right screen shot

how to delete?
Comment 4 John Poelstra 2007-10-29 12:11:51 EDT
Created attachment 242031 [details]
error message
Comment 5 Jeremy Katz 2007-10-29 12:44:32 EDT
What does 'getfacl /dev/snd/*' show?  If you're not in the acl to access the
devices, it might be good to also provide the output of ck-list
Comment 6 John Poelstra 2007-10-29 13:17:17 EDT
everything is owner/group == root
Comment 7 John Poelstra 2007-10-29 13:21:30 EDT
Created attachment 242141 [details]
dev-sound
Comment 8 Jeremy Katz 2007-10-29 13:27:07 EDT
That would be the root of the problem... does ck-list show your user as having
an active session?
Comment 9 Jeremy Katz 2007-10-29 13:56:10 EDT
You disabled ConsoleKit.  Thus, you don't get console permissions as that's part
of what it does.