This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 357401

Summary: install failure with dmraid and livecd
Product: [Fedora] Fedora Reporter: Peter Jones <pjones>
Component: LiveCDAssignee: Peter Jones <pjones>
Status: CLOSED RAWHIDE QA Contact:
Severity: urgent Docs Contact:
Priority: low    
Version: rawhideCC: dcantrell, rolf, wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-11-02 14:05:46 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 235703    

Description Peter Jones 2007-10-29 18:14:51 EDT
+++ This bug was initially created as a clone of Bug #349161 +++
(cloned for Rolf's issue, since I think it's unrelated to Thomas's)

Hi folks:

I have an Intel DP35DP motherboard with the ICH9R chipset / Intel Matrix storage. 

With FC8 Test 3 it doesn't even detect the RAID 1 (fakeraid I know) array in a
way that one can access it.

dmraid -r displays the raid array, but it isn't accessible as a device anywhere
else in /dev.

Interestingly, I don't seem to get much further in FC7 - I get as far as
creating and formatting partitions, but then the installer dies and claims that
the ext3 partition is likely not formatted. On closer inspection the detail in
/var/log/messages seems to indicate an incorrect journal node.

I've spent the last day trying to build a new x86_64 live CD from i386 using
revisor and I'm about to pull my hair out (seems like that doesn't really work
properly either) - attempting to build an FC7 with updates that might be able to
actually install on the RAID.

Do you need more detail?

I'd be glad to help, if someone could point me in the direction of what else I
should try.

Thanks,
Rolf.

-- Additional comment from rolf@stasolutions.co.za on 2007-10-27 15:32 EST --
Just to clarify: 

Thomas seems to be able to install and reboot on FC8T3, I can't even get the
install done off the live DVD (x86_64) for FC8T3/FC7...



-- Additional comment from rolf@stasolutions.co.za on 2007-10-27 16:16 EST --
Created an attachment (id=240711)
Anaconda dump of RAID device initialisation during install of FC8T3
Comment 1 Jeremy Katz 2007-10-30 16:33:12 EDT
Peter reproduced this and tracked down what was going on.  anaconda building
with a fix now
Comment 2 Rolf Poser 2007-10-31 06:44:51 EDT
Great - do you need me to do anything to confirm?

Else I'll just wait for the release...

Thanks a stack
Comment 3 Peter Jones 2007-10-31 10:08:54 EDT
Sure, if you want to test, try this:

Boot the live cd
Open a terminal
su -
swapoff -a
vgchange -an --ignorelockingfailure
run the install

It should work without your failure this way (though there is mkinitrd breakage
in yesterday's tree may cause the resulting install not to boot.)
Comment 4 Rolf Poser 2007-11-01 10:28:02 EDT
Hmm..

I now get "Cannot mount volume" - org.freedesktop.hal.device.interfacelocked -
"the enclosing drive for the volume is locked".

I've tried to see how I can unlock it - is it because of the NTFS partition?

Thanks,
Rolf.
Comment 5 Jesse Keating 2007-11-02 14:05:46 EDT
I have confirmed that the dmraid bug is fixed.  I can install to dmraid that had
an existing install, and it boots after the fact.