Bug 358461

Summary: anaconda exception during z-series install
Product: Red Hat Enterprise Linux 4 Reporter: Unix hopur Skyrr <unixrh>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Severity: high Docs Contact:
Priority: low    
Version: 4.5   
Target Milestone: ---   
Target Release: ---   
Hardware: s390x   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-12-10 18:59:13 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Description Flags
exception occured in anaconda none

Description Unix hopur Skyrr 2007-10-30 15:34:02 UTC
Description of problem:
When installing redhat es 4 update 5 on a ibm zseries 64 bit mainframe I run
into installation failure.  After formating the dasds and picking my packages; I
click on proceed and before the first package gets installed comes up a seperate
window with "Exception Occured" heading.

Version-Release number of selected component (if applicable):
default anaconda version from the redhat es 4.5 install disks used with the
zseries 64 bit/os390x

How reproducible:
Start installation from ssh -X root@server.com
Choose installation language
Choose default language
Choose time zone and so on.

Steps to Reproduce:
1.partition disks
2. choose packages indivually from package selection
3. choose to proceed to install packages
Actual results:

Expected results:

Additional info:

Comment 1 Unix hopur Skyrr 2007-10-30 15:34:02 UTC
Created attachment 243601 [details]
exception occured in anaconda

Comment 2 Brock Organ 2008-07-24 20:06:12 UTC
Hi Unix hopur Skyrr,

Were you running anaconda with the intent on upgrading an existing system, or
were you planning to freshly install a new linux image on those dasd devices?

I had two questions about your issue:

1) If you were trying a fresh install, and the current contents of the devices
are expendable, it would be interesting to know if the same problem occurs if
you re-initialize (format) the dasd devices (either via dasdfmt in linux or
cpfmtxa in CMS in z/VM, for example) and then tried the installation again.

(In the past, there were corner cases with pre-existing LVM PVs that lead to
similar tracebacks to what you've reported above "SystemError: lvcreate failed
for LogVol00")

2) Have you seen the same issue with a newer version of RHEL4 (such as update
6).  I ask because the corner cases from 1) seem to have been reduced in our
internal testing, because of general anaconda and LVM improvements that we've
put into recent update releases.

Hope this helps!  Thanks for your report. :)



Comment 3 Chris Lumens 2008-12-10 18:59:13 UTC
The information we've requested above is required in order to review this problem report further and diagnose or fix the issue if it is still present.  Since it has been thirty days or more since we first requested additional information, we're assuming the problem is either no longer present in the current RHEL release, or that there is no longer any interest in tracking the problem.

Setting status to "CLOSED: INSUFFICIENT_DATA".  If you still experience this problem after updating to our latest RHEL release and can provide the information previously requested, please feel free to reopen the bug report.

Thank you in advance.