Bug 363441

Summary: Dell Latitude D830 Notebook X-Display remains dim after suspend/resume
Product: [Fedora] Fedora Reporter: aron vrtala <aron.vrtala>
Component: xorg-x11-drv-i810Assignee: Adam Jackson <ajax>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 7CC: aron.vrtala, michael_e_brown
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: kernel-2.6.23.1-21.fc7 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-11-30 10:28:26 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
The xorg.conf
none
Xorg.0.log none

Description aron vrtala 2007-11-02 04:07:57 EDT
Description of problem:

S3 sleep causes X-display on notebook to remain dim (too dim to properly read)
after resume. FN-key light controls can't be used any longer (no reaction).
Hibernate will not show this effect . it will actually elevate this problem.
Tried several hal-qirks but no result.

If BIOS seleceted light control via light sensor is used situation with
backlight is better, however controls remain unusable after suspend/resume.

Kernel upgrade from 2.6.22.9-91.fc7 to 2.6.23.1-10.fc7 causes keyboard to fail
in many occasions after suspend/resume causing a full stop (no X-server kill is
possible via keyboard).

System uses intel video driver (i810 & 915resol. will not work).

Version-Release number of selected component (if applicable):

libsmbios bin and libs are installed Version 0.13.10-1.fc7.
xorg-x11-drv-keyboard-1.1.0-3.fc7
xorg-x11-drivers-7.2-6.fc7
xorg-x11-server-Xorg-1.3.0.0-9.fc7
xorg-x11-server-utils-7.2-1.fc7
xorg-x11-drv-i810-2.0.0-4.fc7

lshal reports:

  system.firmware.release_date = '08/08/2007'  (string)
  system.firmware.version = 'A04'  (string)

udi = '/org/freedesktop/Hal/devices/dell_lcd_panel'
  info.addons = {'hald-addon-dell-backlight'} (string list)
  info.bus = 'unknown'  (string)
  info.capabilities = {'laptop_panel'} (string list)
  info.category = 'laptop_panel'  (string)
  info.interfaces = {'org.freedesktop.Hal.Device.LaptopPanel'} (string list)
  info.parent = '/org/freedesktop/Hal/devices/computer'  (string)
  info.product = 'Dell Laptop Panel'  (string)
  info.subsystem = 'unknown'  (string)
  info.udi = '/org/freedesktop/Hal/devices/dell_lcd_panel'  (string)
  laptop_panel.access_method = 'custom'  (string)
  laptop_panel.brightness_in_hardware = false  (bool)
  laptop_panel.num_levels = 1  (0x1)  (int)
  org.freedesktop.Hal.Device.LaptopPanel.method_argnames = {'brightness_value',
''} (string list)
  org.freedesktop.Hal.Device.LaptopPanel.method_execpaths =
{'hal-system-lcd-set-brightness', 'hal-system-lcd-get-brightn
ess'} (string list)
  org.freedesktop.Hal.Device.LaptopPanel.method_names = {'SetBrightness',
'GetBrightness'} (string list)
  org.freedesktop.Hal.Device.LaptopPanel.method_signatures = {'i', ''} (string list)


lspci shows the graphics to be:
00:02.0 VGA compatible controller: Intel Corporation Mobile Integrated Graphics
Controller (rev 0c)

and Xorg says in more detail: 
(--) Chipset 965GM found



How reproducible:

Backlight dim and unusable FN Keys to control backlight: 100%
Keyboard fail after resume: about 60%

Steps to Reproduce:
1. suspend notebook, either on panel using power manager or using pm-suspend
2. resume notebook (either powerswitch or opening the lid
  
Actual results:

backlight stays dim, dellLcdBrightness will not work setting values, Fn-Keys not
working. Sometimes keyboard frozen (only FN-Esc will put the system to suspend
mode again).

Expected results:

backlight at same level as before suspending or at least controllable.
dellLcdBrightness should be able to control backlight. Fn-Keys are expected to
work. Frozen keyboard should never occur.

Additional info:

Several notebooks show this behavior, even if installed with an i386 F7 system
(eg. running x64_86 is not the problem).
Comment 1 Matěj Cepl 2007-11-02 09:03:22 EDT
Would some quirk
(http://people.freedesktop.org/~hughsient/quirk/quirk-suspend-index.html) help?
What I mean is, that you could try to go through
http://people.freedesktop.org/~hughsient/quirk/quirk-suspend-debug.html and play
with pm-suspend so long as it will be working for you.

Please, let us know whether some quirk helps.
Comment 2 Michael E Brown 2007-11-02 12:40:36 EDT
I just found out that my D620 needs the following quirks:

pm-suspend --quirk-vbe-post --quirk-vbemode-restore

These two quirks fix: https://bugzilla.redhat.com/show_bug.cgi?id=358631
 and: https://bugzilla.redhat.com/show_bug.cgi?id=358671

Possibly these would help here?
Comment 3 Matěj Cepl 2007-11-04 10:07:11 EST
Please, see https://bugzilla.redhat.com/show_bug.cgi?id=358631#c9 and continue
accordingly in this bug as well.
Comment 4 aron vrtala 2007-11-05 04:05:02 EST
I've already played days with pm-suspend and different setups of quirks in hal.
Using /usr/share/hal/fdi/policy/10osvendor/10-dell-laptop-brightness.fdi and
/usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-dell.fdi and the
modes described by Michael. I did also try power_management.quirk.no_fb,
power_management.quirk.s3_bios, power_management.quirk.s3_mode, the latter both
together with appropriate change to the kernel. No success.

64bit debugging is unfortunately not possible (as described on
qirk-suspend-debug homepage).

AFAIK D620 and D830 have _different_ video hardware (945 vs 965 chipsets).
Quirks working to D620 need not neccessarily work.
Comment 5 Matěj Cepl 2007-11-07 06:00:15 EST
OK, I give up -- could you please attach to this bug as separate uncompressed
attachments your /etc/X11/xorg.conf and /var/log/Xorg.0.log and I will pass this
bug to developers to sort it out.
Comment 6 aron vrtala 2007-11-07 07:12:59 EST
Created attachment 250011 [details]
The xorg.conf
Comment 7 aron vrtala 2007-11-07 07:13:38 EST
Created attachment 250021 [details]
Xorg.0.log

Just contains hibernates.
Comment 8 aron vrtala 2007-11-07 07:14:07 EST
Attached both requested files. I will capture another Xorg.0.log for with just
one suspend in it. This one has several hibernates in it.

Thank you for help!
Comment 9 aron vrtala 2007-11-13 07:56:09 EST
I just came back to my D830. First I saw lots of updates including new kernel
2.6.23.1-21.fc7. I yum'ed them and tried suspending. While the suspend through
PowerManager (2.18.3) did not let the system resume correctly (see above) it did
do the suspend using pm-suspend --quirk-vbe-post --quirk-vbemode-restore
as described by Michael. I don't overview what's effectively new, but a fully up
to date Fedora 7 will work using this. I think this can be used to program hal.

I'm satified. This issue can be closed by now.

Thank you all, Aron