Bug 364351

Summary: NFS: Fix directory caching problem - with test case and patch.
Product: Red Hat Enterprise Linux 5 Reporter: Jeff Layton <jlayton>
Component: kernelAssignee: Jeff Layton <jlayton>
Status: CLOSED ERRATA QA Contact: Martin Jenner <mjenner>
Severity: low Docs Contact:
Priority: urgent    
Version: 5.0CC: andriusb, chet.burgess, dennis.newport, jplans, k.georgiou, staubach, steved
Target Milestone: rcKeywords: ZStream
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: GSSApproved
Fixed In Version: RHBA-2008-0314 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-05-21 11:00:38 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 364361, 429539, 429839    
Attachments:
Description Flags
patch -- discard pagecahe for dirs on dentry iput none

Description Jeff Layton 2007-11-02 13:55:41 EDT
This patch was pushed upstream last June. The testcase fails on current RHEL4
and RHEL5. Patch fixes RHEL4 and I assume it'll fix RHEL5 as well. Description
of problem and testcase is in the patch description.

There is some speculation that this problem may be related to the problems seen
in  bug 327591. At the very least though, this is a reproducible problem in and
of itself and should probably be fixed.
Comment 1 Jeff Layton 2007-11-02 13:55:41 EDT
Created attachment 246911 [details]
patch -- discard pagecahe for dirs on dentry iput
Comment 2 RHEL Product and Program Management 2007-11-02 14:05:18 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 John Poelstra 2007-12-07 00:38:52 EST
Is said testcase that fails available to QE and if so where?
Comment 5 Chet Burgess 2007-12-07 23:51:21 EST
I recently ran into a NFS directory caching problem on 5.0 as well as 5.1. It
appears that I have encountered bug 364351.

In researching my problem I found bug 327591 and by extension bug 364351. I used
the test script documented in bug 327591 and found at the following URL.
 http://www.linux-nfs.org/Linux-2.6.x/2.6.21/linux-2.6.21-021-fix_readdir_stale_cache.dif


I was able to reproduce the problem on my 5.0, and 5.1 boxes, but not on my 3.8
boxes. I went ahead and tested your RHEL5 test kernels found at the following URL.

http://people.redhat.com/jlayton

I can confirm that the following kernels work in my dev environment and that
they fix bug 364351.

kernel-PAE-2.6.18-58.el5.jtltest.17
kernel-2.6.18-58.el5.jtltest.17
kernel-2.6.18-58.el5.jtltest.17.x86_64

I am cross posting this to both bug bug 364351 and bug 327591 as they are
possibly related and the kernels tested above contain potential fixes for both
bugs, though no test case exists for bug 327591.
Comment 6 Jeff Layton 2007-12-08 06:43:44 EST
John,
   There's a shell script in the patch description of the patch in comment #1.
On a current RHEL5.1 kernel, the tar command will report an error (something
like "File changed as we read it"). With this patch, the script runs without error.
Comment 11 Don Zickus 2008-01-24 11:08:57 EST
in 2.6.18-74.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 13 Mike Gahagan 2008-03-10 17:34:13 EDT
Confirmed bug with the testcase attached using kernel -53.1.4.el5. Confirmed the
fix is working as expected with the -84 kernel.
Comment 16 errata-xmlrpc 2008-05-21 11:00:38 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html
Comment 18 D Newport 2008-10-23 06:06:54 EDT
When creating tar files of our system closure we get multiple error messages saying "file changed as we read it". They all relate to files of the same name that are in different locations, something that is probably common for many users.

This is a non-trivial error because when we try to extract from the archive tar outputs: "Cannot open: No such file or directory".

I will ask that our sys admin guys update the kernel with the info supplied above and then try again. If this patch works for us then I'll let you know. In which case I would recommend you update your severity level because tar is such a critical utility for so many people.

Thanks.