Bug 365281

Summary: HP Photosmart E327 cannot be used by non-root user
Product: [Fedora] Fedora Reporter: David Anderson <david>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 7CC: psj
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-12-04 04:13:58 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description David Anderson 2007-11-03 11:42:21 EDT
The HP Photosmart E327 is a USB PTP camera.

udev doesn't set the permissions to allow it to be used by a non-root user.

I'm a udev novice, but Googling around for tips, I found that the following 
worked for me:

1. Create a file /etc/udev/rules.d/60-hpe327.rules with this line:

ATTR{idVendor}=="03f0", ATTR{idProduct}=="8b02", SYMLINK+="hpe327-%k"

2. Add "/dev/hpe327*" to the "<camera>" line 
in /etc/security/console.perms.d/50-default.perms
Comment 1 Paul Jenner 2007-11-03 18:14:25 EDT
See similar bug #362221

Do you see the same error when you try "gphoto2 --debug --auto-detect --summary"?

Did this used to work or is this the first time you have tried?
Comment 2 David Anderson 2007-11-10 06:59:36 EST
Answer to #1: That command works as root, but as non-root it gives:

*** Error ***
An error occurred in the io-library ('Could not claim the USB device'): Could 
not claim interface 0 (Operation not permitted). Make sure no other program or 
kernel module (such as sdc2xx, stv680, spca50x) is using the device and you 
have read/write access to the device.
*** Error (-53: 'Could not claim the USB device') ***

This is the first time I've tried.

I've found that the camera has a setting for USB mass storage instead of PTP 
so for the time being I'm using that, but it would be nice to have it work 
both ways (PTP is the default).
Comment 3 Paul Jenner 2007-11-15 14:07:59 EST
In which case I believe this is a dup of #362221. Can you close as duplicate if
you agree? Better we get one bug to track all these. Thanks.
Comment 4 David Anderson 2007-12-04 04:13:58 EST

*** This bug has been marked as a duplicate of 362221 ***