Bug 368531

Summary: Radeon dualhead: "Requested Entity already in use!"
Product: [Fedora] Fedora Reporter: Jan "Yenya" Kasprzak <kas>
Component: xorg-x11-drv-atiAssignee: X/OpenGL Maintenance List <xgl-maint>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 8   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-11-06 17:39:02 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
xorg.conf for two separate screens none

Description Jan "Yenya" Kasprzak 2007-11-06 11:59:33 EST
Description of problem:
My workstation has an ATI Radeon 7500 card with two monitors: 1600x1200
connected to the DVI port, and 1280x1024 on the VGA port. I do not use a
MergedFB, Xinerama, or XRandR display, just plain old two separate
screens (:0.0 and :0.1). This setup is no longer working on Fedora 8:

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.7.195-3.fc8.x86_64.rpm

How reproducible:
100%

Steps to Reproduce:
1. Install Fedora 8
2. Use the attached /etc/X11/xorg.conf
3. Run "Xorg"
  
Actual results:
Xorg fails to start with the following message:
"Requested Entity already in use!"

Expected results:
Xorg should start with two separate screens available, as it did in F7 and FC6.

Additional info:
Downgrading to the xorg-x11-drv-ati-6.6.3-4.fc7.x86_64 package from Fedora 7
updates solves the problem.

I do not want to use a merged screen (Xinerama, MergedFB or XRandR), because I
want GNOME workspace switcher to switch virtual desktops on each monitor
separately. This is apparently not possible with one big virtual screen. Also
both of my monitors have different DPI (they are roughly the same height, while
the first one has 1200 pixels height, and the second one has only 1024). So I
want the screen resolution to be reported to the X clients correctly, based on
which screen they run on.

I maintain an official Fedora 8 mirror, in case you wonder where I got the F8
installation media before the release date ;-)
Comment 1 Jan "Yenya" Kasprzak 2007-11-06 11:59:33 EST
Created attachment 249441 [details]
xorg.conf for two separate screens
Comment 2 Dave Airlie 2007-11-06 17:39:02 EST
upstream has deprecated this feature in the ATI driver. randr-1.2 is now the
supported method for dual-head on the ATI driver.

While it might be possible to bring back the functionality, Fedora isn't the
place to annoy, upstream is.
Comment 3 Jan "Yenya" Kasprzak 2007-11-06 17:56:12 EST
OK. I will probably try to bother GNOME people instead: implementing per-monitor
workspace switching could be easier (and more universal) than bringing the
deprecated functionality to the radeon driver.
Comment 4 Jan "Yenya" Kasprzak 2007-11-09 07:11:56 EST
Speaking of upstream - where exactly is the upstream? Is there any ATI-specific
mailing list on x.org?