Bug 371061

Summary: Fedora 8 no more see my internal bluetooth adapter
Product: [Fedora] Fedora Reporter: Alexey Kuznetsov <axet>
Component: bluez-utilsAssignee: David Woodhouse <dwmw2>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 8CC: bnocera, mads, tuju
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-05-21 00:00:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Alexey Kuznetsov 2007-11-08 11:23:39 UTC
Description of problem:

Fedora 7 work fine


How reproducible:
Alltime

Comment 1 Alexey Kuznetsov 2007-11-08 11:24:07 UTC
Hardware: Macbook Pro.

Comment 2 David Woodhouse 2007-11-08 12:27:44 UTC
Edit /etc/sysconfig/bluetooth and make sure it says 'HID2HCI_ENABLE=true'.
That'll fix it on subsequent reboots. For now, just run '/sbin/hid2hci' as root.

There were issues with automatically taking devices out of HID mode (where they
magically connect to keyboards and mice). So we turned that off by default. Lack
of bluetooth is considered to be a less problematic failure mode than lack of
keyboard and mouse.

Please reopen if this isn't the problem.

Comment 3 Chris Snook 2007-11-25 07:52:08 UTC
Not fixing it for me on my Thinkpad T60.  Worked fine in F7.

Comment 4 Joey Boggs 2007-12-12 00:56:27 UTC
chris, here's a workaround for the t60

echo "enable" > /proc/acpi/ibm/bluetooth

The adapter doesn't get turned on for some reason, and the thinkpad key for BT
is ignored


Comment 5 Bastien Nocera 2008-05-21 00:00:08 UTC
(In reply to comment #3)
> Not fixing it for me on my Thinkpad T60.  Worked fine in F7.

That's a kernel problem. https://bugzilla.redhat.com/show_bug.cgi?id=384111

*** This bug has been marked as a duplicate of 384111 ***