Bug 3712

Summary: ifup-aliases doesn't honor gateways on the aliased interface
Product: [Retired] Red Hat Linux Reporter: hagoprm
Component: initscriptsAssignee: Bill Nottingham <notting>
Status: CLOSED NEXTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-09-20 19:17:54 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description hagoprm 1999-06-24 19:33:42 UTC
The ifup-aliases script does not check if the gateway (in
/etc/sysconfig/network) is on an aliased interface. While
not common, it turns out to be a major inconvience when the
primary interface is the internal network (ie. 10.x.x.x on
eth0) and the aliased interface (DSL, cable modem, etc) has
the gateway on it.

The "solution" would be to put the gateway interface on eth0
and have eth0:0 be the internal network, but this could
conceivably fail if the gateway interface fails to come up
and then the aliased interface can't be created.

Comment 1 Jay Turner 1999-06-28 14:41:59 UTC
This issue has been forwarded to a developer for further action.

Comment 2 Bill Nottingham 1999-09-20 19:17:59 UTC
You should be able to change the 'GATEWAYDEV' parameter in
/etc/sysconfig/network.

ifup-aliases has been rewritten for the next release,
and it should fix this.