Bug 37253

Summary: [dma] RH 7.1 install hangs after selecting installation type
Product: [Retired] Red Hat Linux Reporter: Stan Stead <sstead>
Component: kernelAssignee: Arjan van de Ven <arjanv>
Status: CLOSED CURRENTRELEASE QA Contact: Brock Organ <borgan>
Severity: high Docs Contact:
Priority: medium    
Version: 7.1CC: per.winkvist, peter_forsberg
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-05-16 18:37:05 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Stan Stead 2001-04-23 19:44:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)


Installer hangs after "upgrade" selected. install log shows 
* looking for USB mouse...
* no IDE floppy devices found
this is present before the hang

Reproducible: Always
Steps to Reproduce:
1. floppy boot (boot.img)
2. seawolf-i386-disc1 image
3. english->101keyboard, generic PS/2 mouse, enable keys
4. select upgrade
	

Actual Results:  hangs after several minutes of disk and cd activity.
Log shows * no IDE floppy devices found (see above)

Expected Results:  installer continued

Comment 1 Per Winkvist 2001-04-24 05:59:28 UTC
The furthest I got for text, nofb, lowres was this:

VC3:
going to insmod ext3.o
looking for USB mouse
no IDE floppy device found

VC4:
raid5: using funct
raid5: personality registred as nr 4

I could complete the install using expert where it added the following
lines for VC3 when I got to select packages instead of the crash.
Detected 128 of memory
Swap attempt of 128 to 256
Maximum cylinder is 198
...

For text I got this Ooops.
-----------------------------------------
                        Ooops: 0002
CPU:            0
EIP:            0010:[<c8829e37>]
EFLAGS: 00010006
eax: 00000000   ebx: c12ea0f4   ecx: 00000081   edx: 000be40c
esi: c7f1fa10   edi: 00000080   ebp: c12ea078   esp: c0241f14f2
                                                        next screen
ds: 0018        es: 0018        ss: 0018

Process swapper (pid:0, stackpage=c0241000)
Stack c0241f47 c12ea0f4 c12ea078 00000081 c88294d6 c12ea078 c12ea0f4 00000080
c12ea078 c12ea0f4 c0241f47 00000282 912711c0 00000246 00000000 c025f550
00000000 c7f1ea80 04000001 0000000b c0241fac c010a019 0000000b

Call Trace [<c88294d6>] [<c010a019>] [<c010a168>] [<c12ea078>] [<c0107210>]
[<c0108f58>] [<c0107210>] [<c0107233>] [<c010729a>] [<c0105000>] [<c0100191>]

Code: 80 60 27 fe 85 f6 0f 84 9f 00 00 00 80 4e 27 02 e9 96 00 00

Kernel Panic: Aiee, killing interrupt handler
In interrupt handler - not syncing
-----------------------------------------


Let me know if there is something wrong with the oops since I can reproduce it
pretty easy.

I previously had a RH7 installation w/ ~50 swap, 128 ram

Regards,
        Per Winkvist


Comment 2 Brent Fox 2001-04-24 14:35:31 UTC
I think the second post here is a different bug.  Please file a new bug report
against the kernel.

Comment 3 Brent Fox 2001-04-24 14:38:26 UTC
Can you look on VC3 and VC4 and see if there are any interesting messages?



Comment 4 Need Real Name 2001-04-24 18:22:31 UTC
I'm seeing a very similar problem.  After selection of installation type, 
install hangs.  This happens in both the X and text installers.  The last 
message I get in VC3 is "swap attempt of 256M to 512M".

Comment 5 Brent Fox 2001-05-01 15:25:12 UTC
What happens when you boot using 'linux ide=nodma'?  Does this help?

Comment 6 Peter Forsberg 2001-05-03 20:37:23 UTC
Hi, I have experienced this exact problem. My normal CD is a Hitachi GD-2500BX 
DVD drive. RH7.1 installation hanged when using this drive, in exactly the way 
described above.
Following advice I got through the seawolf mailing list, I tried another CD 
drive, an older NEC CDR-3000A - with this drive the install worked just fine.
Finally I switched back to the Hitachi drive and tried an install with 
ide=nodma and this also worked fine.
Maybe the NEC drive does not support DMA and thus worked?
I hope this helps,
  Peter.

Comment 7 Brent Fox 2001-05-04 14:24:56 UTC
You are almost certainly right.  We've seen a lot of these.

Comment 8 Brent Fox 2001-05-09 19:45:29 UTC
Can everyone post the contents of /proc/ide/hdc/model so that we can get the
model name of all the affected cdroms?

Comment 9 Per Winkvist 2001-05-16 18:37:01 UTC
Don't know if you need my info since you said "I believe this is another bug" 
but here it is anyway:
[perra@localhost perra]$ cat /proc/ide/hdb/model
NEC CD-ROM DRIVE:282