Bug 374251

Summary: justified text rendering very slow
Product: [Fedora] Fedora Reporter: Pádraig Brady <p>
Component: firefoxAssignee: Gecko Maintainer <gecko-bugs-nobody>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 8   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-11-12 09:34:12 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Pádraig Brady 2007-11-09 22:53:03 EST
Create a page with lots of text with style="text-align: justify;"
It's really slow to render on 2.0.0.8 (F8) compared to 2.0.0.4 (F7).
Would this be anything to do with new justification support in pango?
http://mces.blogspot.com/2007/05/avoiding-extra-work.html
Comment 1 Matěj Cepl 2007-11-12 05:24:13 EST
Could you provide some URL where this bug is reproducible, so that we can test
it, please?
Comment 2 Pádraig Brady 2007-11-12 05:51:04 EST
(echo '<html><body><div style="text-align: justify;">'; yes whatever | head
-10000; echo '</div></body></html>') > slow.html

Scrolling is also horrendously slow.

Change the 'justify' above to 'left' to see the speed difference.

Hmm, firefox 2.0.0.6 on gutsy has the same slow down, but not just as bad I think.
Comment 3 Pádraig Brady 2007-11-12 06:39:05 EST
An old possibly related mozilla bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=302968
Comment 5 Matěj Cepl 2007-11-12 09:34:12 EST
I agree, with comment 3. This bug has been already registered in the upstream
database (https://bugzilla.mozilla.org/show_bug.cgi?id=302968) and believe that
it is more appropriate to let it be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug
tracker, and will review any bug fixes that become available for consideration
in future updates.

Thank you for the bug report.
Comment 6 Pádraig Brady 2007-11-12 17:52:36 EST
Err you closed that a bit quickly I think.
I only noticed this since Fedora 8, so it may
be a confluence of various factors.

I did a bit of looking around and comparing firefox 1.0.8 on ubuntu 5.10,
that was slower at left justified than ff-2.0.0.8 but much faster at justified.

I also tried different fonts and the default F8 font of Deja Vu
is the slowest by a fair margin. liberation is not too bad.
Microsoft fonts like Calibri are a bit faster again.

Also there was no comment on the recently pango justification support.
I'm unsure hang pango fits into firefox so that might be totally off base.
Comment 7 Pádraig Brady 2007-11-13 16:49:37 EST
I just tried firefox 2.0.0.8 on windows and there is no noticeable
delay at all in scrolling justified text.

I also notice that general.smoothscroll is on by default on ff on Fedora 8
at least, which slows things down a little more.

The rest of my GUI is very fast, running the latest intel X driver
Comment 8 Matěj Cepl 2007-11-14 04:46:35 EST
Padraig, I am not saying that there is no bug here, but that we have no
resources to deal with it inside of Red Hat, so if you want to investigate it
further your comments will be certainly welcome in the upstream bug. When that
is resolved upstream, we will get the fix with the next release of Firefox.
Commenting here is probably waste of your time.