Bug 375631

Summary: cups web interface is not working if rpm is installed with %_excludedocs 1
Product: [Fedora] Fedora Reporter: Peter Bieringer <pb>
Component: cupsAssignee: Tim Waugh <twaugh>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 7   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 1.3.6-4.fc8 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-02-26 12:49:13 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 235705    

Description Peter Bieringer 2007-11-11 04:20:29 EST
Description of problem:

During installation of a minimal flash based print server system (original using
CentOS5) I found, that cups installation is broken, if /root/.rpmmacros contains 
%_excludedocs 1 (or "--excludedocs") is used during installation.


Version-Release number of selected component (if applicable):
cups-1.2.12-6.fc7 (F7)
cups-1.2.4-11.14.el5_0.1 (RHEL5)


How reproducible:
Always


Steps to Reproduce:
1. install cups using --excludedocs
2. start cups
3. try to connect to web interface
  
Actual results:
404 page not found:

* - - [11/Nov/2007:04:08:59 -0500] "GET / HTTP/1.1" 404 0 - -
* - - [11/Nov/2007:04:08:59 -0500] "GET /cups.css HTTP/1.1" 404 0 - 

Expected results:

Working web interface

Additional info:

# rpm -ql cups|grep css
/usr/share/doc/cups-1.2.4/cups-printable.css
/usr/share/doc/cups-1.2.4/cups.css

Looks like package definition or installation process has a mistake, at least
all used web pages needs to be moved, e.g. to /usr/share/cups-1.2.4/
Comment 1 Tim Waugh 2008-02-26 11:41:07 EST
Fixed in CVS.