Bug 381

Summary: Processes go into uninterruptible sleep, preventing syncs and shutdowns
Product: [Retired] Red Hat Linux Reporter: dull
Component: kernelAssignee: David Lawrence <dkl>
Status: CLOSED NOTABUG QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 5.2CC: dull
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1998-12-10 18:45:48 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description dull 1998-12-10 17:36:10 UTC
Currently, I am running Redhat 5.2 and the Sybase database
server.  For some unknown reason, after a large number of
transactions, the Sybase dataserver process goes into a "D"
state (uninterruptible sleep).  Also, some other Sybase
sysmultibuf processes remain.

I have not been able to determine why the dataserver goes
into the "D" state.  It is suspected that there is either s
software bug in the Sybase server or the kernel.

Once the process goes into the "D" state, the file system
capabilities are limited.  I can still access files and do
maintenance, however it prevents admin functions like umount
and sync from being executed.  If these are run, they will
go into a uninterruptible sleep also.

These problems make a software reboot of the system
impossible, because the processes will never shutdown.  A
hard boot is the only method of cleaning the state.

Comment 1 Jay Turner 1998-12-10 18:45:59 UTC
Do not have the resources to replicate this in test lab.  Verify that
you are running the latest version of the 2.1 kernel. as this might
have an effect on the way that things are interacting.