Bug 387731

Summary: cobbler has a broken requirement on syslinux
Product: [Fedora] Fedora Reporter: Christopher Aillon <caillon>
Component: cobblerAssignee: Michael DeHaan <mdehaan>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 7   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-11-16 17:21:50 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Christopher Aillon 2007-11-16 17:03:29 EST
The cobbler package should require syslinux but it doesn't.  The cobbler spec
file says:

%ifarch i386 i686 x86_64
Requires: syslinux
%endif

But this never evaluates to true because the package is noarch.


[root@mithrandir ~]# rpm -qp --requires cobbler-0.6.4-2.fc7.noarch.rpm 
/bin/sh  
/bin/sh  
/bin/sh  
/bin/sh  
/sbin/chkconfig  
/sbin/chkconfig  
/sbin/service  
/usr/bin/env  
/usr/bin/python  
config(cobbler) = 0.6.4-2.fc7
createrepo  
httpd  
mod_python  
python >= 2.3
python(abi) = 2.5
python-cheetah  
python-devel  
rhpl  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
tftp-server
Comment 1 Michael DeHaan 2007-11-16 17:21:50 EST
Correct. 

I've removed it from the specfile (upstream).  We actually don't want to require
syslinux anyway, because cobbler is useful even in non-PXE configurations.

Thanks!

Comment 2 Michael DeHaan 2007-11-16 17:23:53 EST
FYI, regarding not requiring syslinux.  Ideally it would be nice to require it
where it was available to suck it down automatically in yum, but apparently
that's not possible.  That's ok.

We do mention the detected absence of syslinux during 'cobbler check'.  This is
because one might want to install cobbler on ppc/ia64 for serving koan (I don't
know why, but we need not exclude it) ... and we don't have the package
available there.