Bug 3901

Summary: autoexpect says the system has no more PTYs
Product: [Retired] Red Hat Linux Reporter: Andreas Busch <abusch>
Component: exmhAssignee: David Lawrence <dkl>
Status: CLOSED WORKSFORME QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.0CC: abusch
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-08-28 22:16:17 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Andreas Busch 1999-07-05 16:15:50 UTC
BTW: expect-5.28-29.i386.rpm is not listed in components.

expect-scripts and autoexpect script generation doesn't
work anymore with the new Unix 98 pty compiled into the
kernel (my version 2.2.10)
Increasing the number of pty's doesn't solve the problem.

[root@zuse1 /root]# autoexpect
autoexpect started, file is script.exp
The system has no more ptys.  Ask your system administrator
to create more.
    while executing
"spawn -noecho $env(SHELL)"
    (file "/usr/bin/autoexpect" line 317)

Comment 1 Jeff Johnson 1999-08-28 22:16:59 UTC
Make sure that /dev/pts is mounted. You should have a line in
/etc/fstab like
none                    /dev/pts        devpts  gid=5,mode=620  0 0

I don't know of any other problems like this. Please reopen this
bug if my analysis is wrong.