Bug 3960

Summary: ping from netkit-base-0.10-31 returns "wrong data byte"
Product: [Retired] Red Hat Linux Reporter: radu
Component: netkit-baseAssignee: Jeff Johnson <jbj>
Status: CLOSED NEXTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: high    
Version: 6.0CC: radu
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-08-09 20:21:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description radu 1999-07-09 09:12:08 UTC
Successfull pings with a round-trip time higher than one
second give always the error "wrong data byte #8":

[radu@busy radu]$ ping www.taide.net
PING www.taide.net (193.219.193.135) from 193.226.115.211 :
56 data bytes
64 bytes from 193.219.193.135: icmp_seq=0 ttl=251
time=2120.7 ms
wrong data byte #8 should be 0x59 but was 0x57
        57 bb 85 37 61 aa 0 0 8 9 a b c d e f 10 11 12 13 14
15 16 17 18 19 1a 1b 1c 1d 1e 1f
        20 21 22 23 24 25 26 27 28 29 2a 2b 2c 2d 2e 2f
64 bytes from 193.219.193.135: icmp_seq=1 ttl=251
time=2059.8 ms
wrong data byte #8 should be 0x5a but was 0x58
        58 bb 85 37 58 86 0 0 8 9 a b c d e f 10 11 12 13 14
15 16 17 18 19 1a 1b 1c 1d 1e 1f
        20 21 22 23 24 25 26 27 28 29 2a 2b 2c 2d 2e 2f

--- www.taide.net ping statistics ---
4 packets transmitted, 2 packets received, 50% packet loss
round-trip min/avg/max = 2059.8/2090.2/2120.7 ms


The problem appeared after upgrading netkit-base-0.10-29 to
netkit-base-0.10-31. The patch I'll send shortly fixes the
problem.

Comment 1 Jeff Johnson 1999-08-09 20:21:59 UTC
Fixed (by skipping timeval byte comparison) in netkit-base-0.10-33.
Thanks for the patch.

Comment 2 Jeff Johnson 2000-01-20 22:17:59 UTC
*** Bug 8679 has been marked as a duplicate of this bug. ***