Bug 397991

Summary: replace "Release notes are missing" with a URI to actual relnotes
Product: [Fedora] Fedora Reporter: Karsten Wade <kwade>
Component: anacondaAssignee: Jeremy Katz <katzj>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 8   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-01-16 23:29:56 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 235706    

Description Karsten Wade 2007-11-24 14:32:17 EST
Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Karsten Wade 2007-11-24 14:38:38 EST
(Sorry, mis-paste of multiple lines included a CR that sent the bug report

When release notes are not available to Anaconda, clicking on the ''Release
notes'' button yields a screen with the semi-helpful text:  "Release notes are

While it is good that something is displayed so people don't wait and wait for
the blank screen to stop being blank, I suggest we put in a URI and pointer text.

"Release notes are at http://docs.fedoraproject.org/release-notes"

That URL is canonical forever and ever.

It is understood by me that the URI cannot be an actual hyperlink.  I think it
is OK that we don't state that out; life is not yet a hyperlink and it's OK to
copy and paste sometimes.  

The use case for this bug/RFE is a Live CD doing an "Install to Hard Drive"
where there is in fact a browser and connection available.

The other use case is where a documentation person happily clicks on that button
thinking she'll see her hard work displayed, and would appreciate knowing that
hard work was but a browser away.

Thanks - Karsten
Comment 2 Jeremy Katz 2007-11-26 11:45:00 EST
The problem is that the URI is canonical forever and ever, but only for Fedora.
 We could put it into the installclass I guess.

But it's equally likely that we're going to do "something else" about the
release notes for Fedora 9.
Comment 3 Karsten Wade 2007-12-04 02:39:23 EST
docs.fedoraproject.org/release-notes *is* forever and ever, Ah!men.

Anyway, that was the idea of creating the hostname and trying to architect the 
folders in a sane way.  I think we can be sure that is going to be the URL for a
long time.
Comment 4 Chris Lumens 2008-01-16 15:35:16 EST
The release notes button in anaconda has been removed.  If we want to provide
the release notes in the livecd, we could at least stick an icon on the desktop
or something similar.
Comment 5 Karsten Wade 2008-01-16 16:01:20 EST
(In reply to comment #4)
> The release notes button in anaconda has been removed.  

I forget what the plan is for displaying release notes in a full install?  Is
Anaconda going to behave differently in the two situations (live install v. boot
to Anaconda)?

I know that in the live environment we could conceivably have Anaconda call the
web browser instead of a local copy of the relnotes, but that somehow seems
very, very wrong.

> If we want to provide
> the release notes in the livecd, we could at least stick an icon on the desktop
> or something similar.


Should I take this up as a (new) RFE with releng?  I'm presuming it's a part of
composing the spin rather than requiring a new package or the like.

I know we prefer to use Firefox bookmarks for documentation links, but I figure
the live media is a bit different.  Since we have an install icon, it would be
nice to have a link to the release notes *and* to the installation guide.
Comment 6 Jeremy Katz 2008-01-16 23:29:56 EST
For the "traditional" install, the idea is that you've downloaded it and there
should be a link right there.  If you've just gotten the DVD from somewhere, if
you're not looking until you're in the installer, you've also pretty much
already lost if there's anything really important there.  They're on the root of
the iso, so users who are interested can look in advance

For the live case, I'm not really sold on having more links on the desktop... 
if we have "install", "release notes", "install guide", "samples of what you can
do with fedora" on top of the other things already there, it's going to be a bit
crowded and harder to know what the really "interesting" things are.  I'd almost
rather see the default session start a web browser if we were to go to those lengths