This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 399901

Summary: Please target standard terminals, not one-of-a-kind 79 column terminals
Product: [Fedora] Fedora Reporter: Nicolas Mailhot <nicolas.mailhot>
Component: rpmlintAssignee: Ville Skyttä <ville.skytta>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: kvolny, tmz
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-11-27 15:26:41 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 235705    

Description Nicolas Mailhot 2007-11-26 13:59:49 EST
rpmlint very anally tries to force people to create lines of 79 columns max in
descriptions.

No 79-column terminal was ever shipped. That means what rpmlint asks is
incompatible with the defaults of common tools such as fold.

If the intent is to leave some margin, usual mail margin is 72 column not 79.

In other words rpmlint does not make any sense nor follows any common convention
which is wasting the time of everyone involved (not to mention no one is
actually limited to 80×25 terminals nowadays)

Please fix to at least standard 80 column width.

rpmlint-0.81-1.fc8.noarch
Comment 1 Ville Skyttä 2007-11-27 15:26:41 EST
Some editors wrap 80-column lines so that the 80th char is wrapped to the next
line in their default settings.  Some others and especially terminals make it
difficult to see whether the line following a 80 char one is attached to the 80
char one or a new line.

Even though the issue is a very cosmetic one considering %description and
Summary, as far as I'm concerned, 80 as the max line length is a no go, but I
wouldn't mind 72.  But because it's a matter of taste, I'm not inclined to make
any changes to this without a public mailing list discussion that reaches some
kind of a conclusion -> WONTFIX.  If such a discussion and conclusion takes
place, feel free to reopen and I'll make changes accordingly.
Comment 2 Karel Volný 2009-09-07 06:51:44 EDT
you may be interested in bug #521630 which may fix you issue - but if you insist on changing the default, just initiate the discussion ...