Bug 401

Summary: cardmgr error caused by bad GATEWAY address
Product: [Retired] Red Hat Linux Reporter: rbucker
Component: installerAssignee: David Lawrence <dkl>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2CC: wangsmo
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-07-15 17:46:00 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description rbucker 1998-12-12 17:35:55 EST
/etc/network had a line:

GATEWAY=0.0.0.0

During the install, I had selected 'no gateway'  When I
finally rebooted, there was a cardmgr error message in
/var/log/messages.  cardmgr[220]... (sorry, I do not have a
record)

when I debuged /etc/sysconfig/network-scripts/ifup, I
determined that there was a 'route add default gw $GATEWAY
$DEVICE' statement.  When I tried the statement manually,
with '0.0.0.0' I received the same error message.

CONCLUSION:
either remove GATEWAY from the network file, or fix 'route'
to support 0.0.0.0
Comment 1 Matt Wilson 1999-01-11 22:50:59 EST
Was this verified?
Comment 2 Mike Wangsmo 1999-01-12 12:00:59 EST
No, and I don't remember why I assigned it to you.  I've reassigned
the bug to Dave and he can verify it.
Comment 3 Matt Wilson 1999-03-13 17:10:59 EST
What is the status of this bug?
Comment 4 David Lawrence 1999-06-29 14:38:59 EDT
Thsi has been verified with 5.2. A line created in
/etc/sysconfig/network by the install

GATEWAY=0.0.0.0

causes the following error in .var/log/messages

June 29 13:36:39 test221 cardmgr[220]: + SIOCADDRT: Invalid argument
Comment 5 Bill Nottingham 1999-07-15 17:46:59 EDT
this was fixed in the 6.0 installer