Bug 409031

Summary: FEAT: [RHEL6.0] LVM split/merge-operations
Product: Red Hat Enterprise Linux 6 Reporter: Issue Tracker <tao>
Component: lvm2Assignee: Jonathan Earl Brassow <jbrassow>
Status: CLOSED WONTFIX QA Contact: Corey Marthaler <cmarthal>
Severity: high Docs Contact:
Priority: high    
Version: 6.0CC: agk, coughlan, devonab, dgunchev, duck, dwysocha, gergnz, heinzm, james.leddy, jbrassow, jim, jkirklan, jscalia, ltroan, mbroz, pcfe, prockai, rdassen, rdoty, riek, ssaha, tao, zxvdr.au
Target Milestone: rcKeywords: FutureFeature, OtherQA
Target Release: 6.2   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-08-31 15:01:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 391521, 494837, 679516, 699280, 729764    

Comment 7 Dave Wysochanski 2008-07-14 14:42:14 UTC
1. Feature request:
The LVM implementation shall support HP-UX-style lvsplit(1M) and lvmerge(1M)
operations. 

The lvsplit operation allows splitting a mirrored logical volume into two
initially identical logical volumes. The lvmerge operation is the inverse
operation of lvsplit. In case of mirrored logical volumes, this is superior to
snapshots in the following aspects:

1. A temporary snapshot of the volume can be made by detaching one of its
mirrors, requiring no additional space reservation.

2. There is no efficient way to convert a snapshot volume into a normal volume,
whereas an lvsplit operation directly results in creation of two normal volumes.
This is an efficient way to implement upgrade with rollback.

3. Combined with vgsplit(8), vgexport(8), and vgimport(8), this gives a
possibility to easily replicate a snapshot of an entire volume group to another
node, provided that it contains only mirrored logical volumes.

2. Description more details.
 Architectures:  Minimally x86, x86_64, but as 
    implementation is architecture-neutral, it 
    shall be available everywhere.  
 Dependencies:  None known.  
 External links:  N/A.  
 Priority (Must Have, High, Medium, Low):  High.  
 Target Releases:  RHEL5.3


Comment 8 Dave Wysochanski 2008-07-14 14:57:09 UTC
Discussion today on LVM call.  Summary is as follows.

Naming and options for commands (lvsplit / lvmerge) remains undecided.  Some
thoughts were that the name of the LV would be needed for lvmerge, and some
lvcreate options might be used.  Need to specify which image to pull out -
probably just a list on the end.

Most of the lvsplit logic is probably in existing lvconvert code; thus lvsplit
may just be a wrapper around the existing lvconvert logic.

lvmerge functionality / implementation was not as clear.  Might be implemented
with snapshot merging code being worked on.

Heinz's replication code may be a more general case of the requested lvsplit /
lvmerge functionality.

Comment 11 Russell Doty 2008-09-19 15:02:55 UTC
Since this didn't make RHEL 5.3, moving it to RHEL 5.4. Cleared pm ACK and raised priority.

Comment 13 Daniel Riek 2008-11-03 19:47:45 UTC
This enhancement request was evaluated by Red Hat Product Management for inclusion a Red Hat Enterprise Linux minor release.

Red Hat does not currently plan to provide this enhanced functionality in a Red Hat Enterprise Linux minor release for currently deployed products.

With the goal of minimizing risk of change for deployed systems, and in response to customer and partner requirements, Red Hat takes a conservative approach when evaluating enhancements for inclusion in minor releases for currently deployed products. The primary objectives of update releases are to enable new hardware platform support and to resolve critical defects.

For more information on Red Hat Enterprise Linux maintenance policies, please consult: http://www.redhat.com/security/updates/errata/

However, Red Hat will further review this request for potential inclusion in future major releases of Red Hat Enterprise Linux.

This enhancement is not yet committed for inclusion in future major release.

Comment 22 Sayan Saha 2010-11-29 15:57:40 UTC
Postponing this for consideration in RHEL 6.2 after evaluation if the existing --splitmirror option addresses the requirements.

Comment 26 Sayan Saha 2011-05-26 17:59:17 UTC
This feature has extensive architectural implications w.r.t the LVM mirroring code that is planned to be sorted out in RHEL 6.3 time-frame. Moving this to  RHEL 6.3 for inclusion considerations during 6.3 planning.

Comment 27 Sayan Saha 2011-08-19 16:10:15 UTC
This feature shall get supported as a result of the work that is presently underway to allow md (software RAID) to be accessed through LVM. Currently looking at RHEL 6.4 and 7.0 time-frame for full support.

Comment 30 Jonathan Earl Brassow 2011-08-31 15:01:45 UTC
The ability to split an image from a mirror and later merge it back will not be implemented using the 'mirror' segment type.  Instead, LVM is adding support for MD's RAID personalities (RAID 1/4/5/6), and the feature will be provided via the 'raid1' segment type - a new mirroring implementation.  Progress on the split/merge feature can be found in bug 732458.