Bug 4112

Summary: ghostscript doesnt display grays
Product: [Retired] Red Hat Linux Reporter: o.schnapauff
Component: ghostscriptAssignee: Preston Brown <pbrown>
Severity: medium Docs Contact:
Priority: high    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: alpha   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-09-23 18:32:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description o.schnapauff 1999-07-19 14:46:51 UTC
see also: bug on xfig

A RH 6.0 alpha system PC 164 LX w Matrox Millenium II with
all updates
till today.

After upgrading to ghostscript-5.10 it doesnt display any
gray colored areas
in documents. A remote running ghostscript from a RH 6.0
ix86 system (without
the XFree updates)
does work ok, so I assume its not directly an X problem.  I
am unsure if the
problem started after the update to RH 6.0 from 5.2 or after
the recent X updates.

reverting to ghostscript-4.10 from RH 5.2 fixes the problem.

Comment 1 o.schnapauff 1999-08-15 23:43:59 UTC
I just tried with gs 5.50, same problems. No grays rendered.

Also gs lower than 5.5 produces erroneous pdfs out of eps for me,
specifically is cannot render  squares with one line missing, it
always renders them with all 4 lines. Test file on request. 5.50 can
convert these correctly under x86 and alpha. Under alpha the grays
problem remains.

Comment 2 Preston Brown 1999-08-23 15:56:59 UTC
can you please attach a test .ps file?  Send it as an e-mail and it
will be attached.

We can't use GS 5.50, the license forbids it.  We may only use the
GPLed 5.10 version for now.

Comment 3 Bill Nottingham 1999-08-24 19:59:59 UTC
ghostscript built with gcc-2.95.1 does not display this behavior,
so it's apparently a compiler bug.

Comment 4 Bill Nottingham 1999-08-24 20:26:59 UTC
In the meantime, ghostscript-5.10-10, which will be in the next
Raw Hide release, should work.

Comment 5 Jim Kingdon 1999-08-24 21:29:59 UTC
Do you know anything about what code in ghostscript is causing
the problem?  Without further investigation, it is hard to know
whether the compiler is indeed buggy or whether this is caused by
some of the non-comformant code in ghostscript (which I know there
is some of - e.g. see comments in gs5.10-rth.patch although that
particular case is presumably worked around).

I don't know if there is a "policy" about what part of the diagnosis
you should do, Bill, and what I should do, but the first step is to
find the part of ghostscript which is being compiled wrong.  Of course
the workaround in -10, of turning off optimization, might be best
for the short run.

Comment 6 Jim Kingdon 1999-08-31 22:16:59 UTC
The problem not fixed in -10 is presumably unrelated to a compiler
bug.  The problem fixed in -10 may be a compiler bug (or may not)
but we would need more information to say (for example, does
-O2 -fno-strict-aliasing fix it like omitting -O2 does?).

(in response to the following email, duly archived):

  Checked ghostscript-5.10-10 from rawhide: fixes the "cannot render
  problem. Does NOT fix the "incorrectly translates a drawn bracket
  to a
  rectangle when translating ps -> pdf" problem.

Comment 7 Preston Brown 1999-09-23 18:32:59 UTC
grays problem fixed for next release, we aren't sure of the pd --> pdf